Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#8788 closed defect (fixed)

T & E plugin always in need of an upgrade

Reported by: chowell@… Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

I am running Trac 0.12 on a Windows 2003 server, served up via Apache 2.2 with Python 2.7.

The issue that I am running into is I installed the T & E plugin with permissions branch the exact egg is timingandestimationplugin 1.1.3b, timingandestimationplugin-1.1.3b-py2.7.egg. The plugin downloaded and installed except for when I enable TimeTrackingSetupParticipant Then the admin tells me I am in need up of an upgrade.

I launch the command prompt, run the trac-admin upgrade, which reports that T& E is in need of an upgrade. The upgrade runs, suggest I upgrade the wiki as well which I do. I restart apache, ensuring that the trac.ini plugin hasn't had it's permissions changed, redeploy and am still told that the T & E plugin is in need of an upgrade and to run upgrade via trac-admin. When I go back to the command prompt and re-run the upgrade, the initial message sasys T& E is in need of an upgrade in the DB, it doesn't seem to matter how many times I run the upgrade, trac-admin still says it's in need of a DB upgrade, and therefore so does the web admin.

Have attached log file.

Attachments (1)

trac.log (555.6 KB) - added by chowell@… 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by chowell@…

comment:1 Changed 3 years ago by bobbysmith007

I looked at the log file you uploaded and see that the thing triggering the upgrade is this plugins custom fields do not seem to be installed.

# fields:True means we are need to add the fields: "billable, totalhours, hours, estimatedhours, internal"
2011-05-11 14:49:49,085 Trac[api] DEBUG: T&E NEEDS UP?: sys:False, rep:False, stats:False, fields:True, man:False

Is there any reason that any of those fields would not be in the "ticket-custom" section of your trac.ini (such as you having intentionally removed them)? The install process puts these in place, so I cannot see why they would be missing unless some the upgrade script doesnt have permission to write to the trac.ini and it is not noticing that, or you are manually removing the fields.

Additionally I noticed that it was requiring the order of some of the fields to be specified (ie: totalhours.order must exist in the trac.ini). It also installs this ordering during the upgrade process, so this shouldn't be a problem, however, I removed this check in version 1.1.4 and 1.1.4b which will be pushed up shortly.

If you still cannot figure out how to get this to work or the upgrade to succeed, please post your trac.ini and maybe I can spot whats going wrong (dont forget to remove an database connection info and other sensitive information before you do). I dont recall these fields being installed ever being a problem in the past but there is a first time for everything

HTH & Cheers,
Russ

PS your ticket-custom section should look something like:

[ticket-custom]
billable = checkbox
billable.label = Billable?
billable.order = 3
billable.value = 1
estimatedhours = text
estimatedhours.label = Estimated Number of Hours
estimatedhours.order = 1
estimatedhours.value = 0
hours = text
hours.label = Add Hours to Ticket
hours.order = 2
hours.value = 0
internal = checkbox
internal.label = Internal?
internal.order = 5
internal.value = 0
totalhours = text
totalhours.label = Total Hours
totalhours.order = 4
totalhours.value = 0

comment:2 Changed 3 years ago by bobbysmith007

[10182] removed some parts of the fields upgrade check to make it more configurable 1.1.4 and 1.1.4b

comment:3 Changed 3 years ago by chowell@…

  • Resolution set to fixed
  • Status changed from new to closed

Apparently some of my fields were slightly off in ticket-custom field.

comment:4 Changed 3 years ago by bobbysmith007

Thanks for updating the ticket. If you have a chance, I would be interested to know how they got "slightly off". I mostly want to verify that it is not a bug in the installer script.

Thanks,
Russ

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.