Opened 3 years ago

Closed 14 months ago

#8920 closed defect (fixed)

Install requirements pull dev release of Trac

Reported by: cory.pedersen@… Owned by: izzy
Priority: low Component: LogViewerPlugin
Severity: minor Keywords:
Cc: Trac Release: 0.11


Installing this plugin on 0.12 causes easy_install to look for a version <0.12, and the candidate that it picks is the 0.12 dev version. This is more of a problem with the easy_install parameter handling, but an FYI.

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by anonymous

The problem ist that the install_requires paramter in specifies "Trac<0.12". Since the plugin works perfectly with Trac 0.12, it should be something like "Trac<=0.12.99" instead.

This bit me when I uploded this plugin as an egg file through teh Admin Panel and it didn't show up in the list of plugins without any error message (except in the log file ;) ).

comment:2 Changed 14 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

(In [13222]) Fixes #8920: Allow plugin to be installed on Trac >= 0.12.

Add Comment

Modify Ticket

as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from izzy. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.