Modify

Opened 3 years ago

Closed 2 years ago

#8949 closed defect (duplicate)

AttributeError: 'NoneType' object has no attribute 'youngest_rev'

Reported by: wgreen Owned by: rjollos
Priority: high Component: RepoSearchPlugin
Severity: blocker Keywords:
Cc: helend, hasienda, ejucovy Trac Release: 0.12

Description

Receiving the following error when conducting a source search after installing the plugin:

AttributeError: 'NoneType' object has no attribute 'youngest_rev'

We're running Trac 0.12.2 on RHEL 6.1.

Thank you.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by rjollos

  • Cc helend hasienda added

Hello,

I took over maintainership of this plugin from athomas some time ago. There is a significant amount of work to do on this plugin, and I don't foresee having the time to do it all.

helend has written the TracSuposePlugin, which seems like a much better solution. Rather than writing the repository search functionality from scratch, a Trac interface to an existing repository search tool has been created. Rather than throwing more effort at this plugin, I'd prefer to help helend with enhancements to the TracSuposePlugin, or spend my time on other Trac plugin projects altogether.

I'd like to get some feedback and hear if anyone knows of a compelling reason to continue this project rather than moving to the TracSuposePlugin. Is there functionality in this plugin that doesn't exist in the TracSuposePlugin? I'm open to hearing all opinions and suggestions.

I'll leave these tickets open for about a week, but in all likelihood will close all of them and deprecate the plugin.

Thanks for your time,

  • Ryan

comment:2 Changed 3 years ago by helend

Supose (0.6.2) can not just search head revision.

comment:3 Changed 2 years ago by rjollos

  • Cc ejucovy added
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7046, and I'd suggest trying out the MultiRepoSearchPlugin.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.