Modify

Opened 3 years ago

Closed 3 years ago

Last modified 19 months ago

#9068 closed defect (duplicate)

ProgrammingError: (1064, "Fehler in der SQL-Syntax. Bitte die korrekte Syntax im Handbuch nachschlagen bei 'c WHERE c.id > 0 ORDER BY c.timestamp LIMIT 30 OFFSET 0' in Zeile 1")

Reported by: sdorn Owned by: rjollos
Priority: normal Component: TracDownloaderPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a GET operation on /admin/general/downloader/stats, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'general',
 'get_2': None,
 'get_3': None,
 'get_4': None,
 'page': None,
 'page_part': u'stats',
 'panel_id': u'downloader',
 'path_info': u'stats',
 'sel_id': None,
 'sel_type': None}

User agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

System Information

Trac 0.12.2
Babel 0.9.5
Genshi 0.6
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
MySQL server: "5.0.90-community-log", client: "5.0.90", thread-safe: 0
MySQLdb 1.2.3
Pygments 1.3.1
Python 2.7.1 (r271:86832, Jan 1 2011, 23:06:49)
[GCC 3.4.6]
pytz 2010o
setuptools 0.6c11
SilverCity 0.9.7
Subversion 1.6.16 (r1073529)
jQuery 1.4.2

Enabled Plugins

TracAccountManager 0.3.1
TracDownloader 0.1

Python Traceback

Traceback (most recent call last):
  File "build/bdist.linux-i686/egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-i686/egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/trac/admin/web_ui.py", line 121, in process_request
    path_info)
  File "build/bdist.linux-i686/egg/tracdownloader/admin.py", line 137, in process_admin_request
    template = self._serve_stats_admin(req)
  File "build/bdist.linux-i686/egg/tracdownloader/admin.py", line 229, in _serve_stats_admin
    template = self._render_stats_table(req)
  File "build/bdist.linux-i686/egg/tracdownloader/admin.py", line 383, in _render_stats_table
    page)
  File "build/bdist.linux-i686/egg/tracdownloader/model.py", line 987, in fetch_downloads_list
    (q_attr_sort,)
  File "build/bdist.linux-i686/egg/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "build/bdist.linux-i686/egg/MySQLdb/cursors.py", line 174, in execute
    self.errorhandler(self, exc, value)
  File "build/bdist.linux-i686/egg/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
ProgrammingError: (1064, "Fehler in der SQL-Syntax. Bitte die korrekte Syntax im Handbuch nachschlagen bei 'c     WHERE  c.id > 0       ORDER BY c.timestamp  LIMIT 30 OFFSET 0' in Zeile 1")

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by anonymous

  • Component changed from SELECT A HACK to DocRenderPlugin
  • Owner changed from anonymous to bsavelev

comment:2 Changed 3 years ago by anonymous

  • Component changed from DocRenderPlugin to DownloadsPlugin
  • Owner changed from bsavelev to Blackhex

comment:3 Changed 3 years ago by anonymous

  • Component changed from DownloadsPlugin to TracDownloaderPlugin
  • Owner changed from Blackhex to peca

comment:4 Changed 3 years ago by rjollos

  • Owner changed from peca to rjollos
  • Status changed from new to assigned

Duplicate of #6180.

comment:5 Changed 3 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:6 Changed 19 months ago by rjollos

See also #4214.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.