Modify

Opened 3 years ago

Last modified 14 months ago

#9103 assigned defect

Closed parents with open children

Reported by: david.killick@… Owned by: walnut
Priority: normal Component: ChildTicketsPlugin
Severity: normal Keywords:
Cc: ludovic.belliere@… Trac Release: 0.12

Description

  • Tracchildtickets: 2.4.4
  • Trac: 0.12.2

We have a parent ticket that has been closed, however at least one of its children has not.

We now want to close the child ticket, however we cannot as the parent is closed, and the ticket update form reports:

Warning: The ticket field 'parent' is invalid: The parent ticket (#7328) is not an active ticket (status: closed).

I've not tested, but it seems that it would in fact be impossible to make any changes to an open child ticket once the parent has been closed.

I have tested closing parent tickets with open children, and it seems that this is not prevented.

Attachments (1)

tickets-with-workflow.patch (934 bytes) - added by walnut 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 years ago by anonymous

  • Owner changed from walnut to anonymous
  • Status changed from new to assigned

You're correct, once a parent is in the 'closed' state, then doing anything with any of the children is not possible.

Can you give me more details of how you've got things set up.... It should not be possible to close a parent when child tickets are still open, I've tested this and I cannot reproduce the behaviour.

Do you use the standard ticket workflow or have you modified it somehow? Are you sure the parent tickets were not 'resolved' when the plugin was disabled or before it was configured?

The plugin checks for the 'resolved' action on a parent ticket and then checks that all its children have the 'closed' state. Is there another way to 'resolve' a ticket (I can only think that you've modified the workflow so that there is another 'action' that brings the ticket to the 'closed' state...???)

Regards
Mark

comment:2 Changed 3 years ago by walnut

  • Owner changed from anonymous to walnut
  • Status changed from assigned to new

comment:3 Changed 3 years ago by walnut

  • Status changed from new to assigned

comment:4 Changed 3 years ago by david.killick@…

That makes sense, we have a custom workflow where there are several actions that can close a ticket depending on its type, and where in the lifecycle it is, and none of them are called 'resolve'.

Can supply some examples if it would be useful, but they are all of the form:

<action_name> <some_state> -> closed
<action_name>.operations = set_resolution
<action_name>.name = Message specific to closing at this point in process
<action_name>.permissions = <permission>

Changed 3 years ago by walnut

comment:5 Changed 3 years ago by walnut

Hi David

I've attached a patch to the ticket with some changes in the childtickets.py file (I try and get the possible actions leading to a 'closed' state and look for them instead of just relying on there being a 'resolve' action).

I'd be greatful if you could rebuild with the patch and let me know if it fixes your problem (or at least prevents you from 'resolving' a parent with open children!)

If it works, I'll check it into svn and make a new release.

Thanks
Mark

comment:6 Changed 2 years ago by ludovic.belliere@…

  • Cc ludovic.belliere@… added

I don't think he got the notice about your patch.

Also, I'd rather have the ability to propagate the resolve status and message of all children alongside the master ticket.

comment:7 Changed 14 months ago by gsanchez@…

Hi, I have the same problem.
How can apply the patch to a working environment? Thanks a lot.

Add Comment

Modify Ticket

Action
as assigned .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.