Modify

Opened 3 years ago

Closed 22 months ago

#9105 closed enhancement (fixed)

Python 2.4 Compatibility

Reported by: guidod Owned by: t2y
Priority: low Component: TracCronPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

Trac 0.12 does still officially support Python 2.4. Here are a couple of patches to make the plugin compile with it.

  • trac-cron-plugin/trac-cron-plugin.no-as-keyword-core-01.patch
  • trac-cron-plugin/trac-cron-plugin.no-empty-baseclass-core-02.patch
  • trac-cron-plugin/trac-cron-plugin.no-empty-baseclass-listener-01.patch

Pre-built packages for CentOs-5 / RHEL5 can be downloaded from the Open Build System at https://build.opensuse.org/package/show?package=trac-cron-plugin&project=home%3Aguidod%3Atrac12

Attachments (3)

trac-cron-plugin.no-as-keyword-core-01.patch (217 bytes) - added by guidod 3 years ago.
trac-cron-plugin.no-empty-baseclass-core-02.patch (252 bytes) - added by guidod 3 years ago.
trac-cron-plugin.no-empty-baseclass-listener-01.patch (283 bytes) - added by guidod 3 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 23 months ago by t2y

  • Owner changed from tbressure to t2y

comment:2 Changed 22 months ago by rjollos

  • Description modified (diff)

comment:3 Changed 22 months ago by t2y

OK, I will!

comment:4 Changed 22 months ago by t2y

  • Resolution set to fixed
  • Status changed from new to closed

I fixed and released into 0.3.1-release. I appreciate your efforts if you will double-check it.

https://pypi.python.org/pypi/TracCronPlugin

Add Comment

Modify Ticket

Action
as closed The owner will remain t2y.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.