Modify

Opened 8 years ago

Closed 4 years ago

#919 closed defect (wontfix)

External links shouldn't appear in the sitemap

Reported by: stava@… Owned by: martin_s
Priority: normal Component: GoogleSitemapPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

First of all, great plugin: long needed.

The produced sitemap.xml should contain internal links only.
The GoogleSiteMap plugin registeres all external links as well.

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by datenimperator

Hi, thanks for the praises... :-) what do you mean with "external"? The plugin will enumerate all wiki pages and put the in the sitemap, and will exclude those last edited by user "trac" by default. (You can override this) What else should it do?

comment:2 Changed 8 years ago by stava@…

Well, since you ask: take a look at http://linadd.org/sitemap.xml.
I would have expected all http://www.linadd.org links to be present,
but not external links like: www.rpm.org or www.opensuse.org.

comment:3 Changed 8 years ago by datenimperator

  • Status changed from new to assigned

Now, this is strange. I've double-checked the code, it iterates over all the wiki pages in your system. It doesn't even know about links, external nor internal...

However, could this be some effect because of individual plugin configuration that you've on your server? Would you mind sending me a dump of your wiki, just to let me try to reproduce the error here?

comment:4 Changed 8 years ago by anonymous

Well, no problem at all, but how do I send you a "dump of my wiki"?
In any case, the http://www.linadd.org/sitemap.xml shows you what I mean.

comment:5 Changed 4 years ago by martin_s

  • Owner changed from datenimperator to martin_s
  • Status changed from assigned to new

comment:6 Changed 4 years ago by martin_s

  • Resolution set to wontfix
  • Status changed from new to closed

The version for Trac 0.10 is abandoned. Please use the new version for Trac 0.11.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.