Modify

Opened 3 years ago

Closed 5 months ago

#9264 closed enhancement (wontfix)

Replace ticket field title "Keywords" with "Tags"

Reported by: rjollos Owned by: hasienda
Priority: normal Component: TagsPlugin
Severity: normal Keywords: field label
Cc: otaku42, jun66j5, mitar, itamarost, lkraav Trac Release: 0.11

Description

I've found that users are confused from time to time by the use of Keywords for the field title on the ticket form, and Tag under for the field title on the wiki edit page.

Perhaps through some template magic we can modify the Trac ticket form to display Tags or Tag under?

Attachments (0)

Change History (14)

comment:1 Changed 3 years ago by hasienda

  • Cc otaku42 jun66j5 mitar itamarost added
  • Keywords field label added

The Keywords label is localized and repeated in a number of different places, not only Ticket form, but TracQuery and TracReports come to mind as well. So wouldn't it be smart the other way around? We have full control over the additional field added to wiki edit page.

Make Tag under read Keywords too. What do you think?

comment:2 follow-up: Changed 3 years ago by mitar

I would go with this question to Trac developers' mailing list. We should push this change upstream: to change keywords to tags. Or change tags to keywords. But we should discuss this with core developers. Maybe they would agree with changing ticket keywords to tags and the problem is solved.

comment:3 follow-up: Changed 3 years ago by itamarost

I think the term "Tags" is more common than "Keywords" for the use-case in Trac, so I +1 for going with Keywords->Tags.

I agree this should be pushed upstream.

comment:4 in reply to: ↑ 3 Changed 3 years ago by hasienda

Replying to itamarost:

I agree this should be pushed upstream.

If no one else feels like doing so, I'll try to raise the question this week. But trac-dev seems not very active these days, so I'm not overly confident, that we get an echo without speaking up rather disturbing. I've still to sleep about this once or twice.

comment:5 follow-up: Changed 3 years ago by osimons

Doesn't such a change have the potential to confuse things even further? Seeing the option ticket_fields exists, and the docs even provides example of ticket_fields = component, keywords? Keywords are just one element in tags, but renaming the field will make it seem like a 1:1 relationship. Which can be just as wrong.


comment:6 in reply to: ↑ 5 Changed 3 years ago by rjollos

Replying to osimons:

Keywords are just one element in tags, but renaming the field will make it seem like a 1:1 relationship. Which can be just as wrong.

I think I see what you are saying. There are ticket keywords, and blog post categories and wiki page tags and they are all classified as tags for the various realms. Do you have any objection to renaming Tag under on the wiki edit page to Keywords?

comment:7 Changed 3 years ago by AdrianFritz

IMHO, a think renaming "tag under" to "keywords" is a good idea.

comment:8 in reply to: ↑ 2 Changed 3 years ago by hasienda

Replying to mitar:

I would go with this question to Trac developers' mailing list.

Done now, as I think, this would profit from a broader audience and discussion. Thank you all, who already joined in to help me resolve the request on or another way.

comment:9 Changed 3 years ago by lkraav

  • Cc lkraav added

i for one support "tags" for the unifying term replacing "keywords", "categories", "labels", as i think it has the widest compatibility with everything software around it.

comment:10 Changed 2 years ago by hasienda

You've certainly noticed the apparent lack of interest?

The mailing list is the reference here. If no agreement, not even a short statement from core developers could be reached, it's rather pointless to heat up on this very issue. Guess just not the time now.?

comment:11 Changed 2 years ago by rjollos

Yeah, it is probably not worth dwelling on if it isn't bothering anyone else.

comment:12 Changed 2 years ago by alexandrul

IMHO, since Trac is not always the only wiki/bug tracker in a given company, it might be useful to switch to tags, just like DokuWiki, MantisBT, YouTrack, and StackOverflow are doing right now. It's a kind of small blocker for Trac adoption in my company.

comment:13 follow-up: Changed 5 months ago by rjollos

While this ticket could be a useful as a future reference, I don't see much sense in keeping it open given that there is no strong consensus on which action should be taken. My current feeling is that the issue can be addressed if a subset of TagsPlugin is ever integrated into the Trac core, possibly by replacing Keywords with Tags in the ticket form.

comment:14 in reply to: ↑ 13 Changed 5 months ago by hasienda

  • Resolution set to wontfix
  • Status changed from new to closed

Replying to rjollos:

While this ticket could be a useful as a future reference, I don't see much sense in keeping it open given that there is no strong consensus on which action should be taken.

Agreed.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.