Modify

Opened 3 years ago

Closed 3 years ago

#9519 closed defect (fixed)

The Trac Environment needs to be upgraded.

Reported by: anonymous Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords: waiting-for-feedback
Cc: Trac Release: 0.12

Description

Hello,

I installed Trac a few days ago. I tried to install the TimingAndEstimationPlugin yesterday. But it does not run. I used the Version for "Trac 0.12 without permissions".

I installed it globally with: python setup.py install

then I used the command: trac-admin /var/trac upgrade

and the Apache2 was restarted.

But the Trac installation does not run anymore.

Error
TracError: The Trac Environment needs to be upgraded.
Run "trac-admin /var/trac upgrade"

I tried it with an absolutely clean installation of Trac. After the installtion of the Plugin it does not run with apache2. The tracd daemon does run.

Greetz..

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by bobbysmith007

A couple of things:

  • Please verify that the trac-admin upgrade call did not change permissions on your trac.ini file. In trac12 this has been a recurring problem that manifests in many different errors that do not make much sense. The tracd, since it runs as a different user typically experiences different errors. Usually this bug is caused by apache processes being unable to read tracs configuration.
  • If the above does not fix your problem, please enable TracLogging, and attach a log file detailing the errors that are causing it to fail
  • Please include relevant version numbers for all the software (these can be obtained from the "about" page when logged in as admin). (It sounds like you should be able to get to this page using tracd).

Cheers, hope we get you squared away soon,

Russ

probably related to #8575

comment:2 Changed 3 years ago by bobbysmith007

  • Keywords waiting-for-feedback added

comment:3 Changed 3 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

That was it. After correct the Fileowners it runs.

Thank you for help.

Greetz.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from bobbysmith007. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.