Modify

Opened 3 years ago

Closed 2 years ago

#9548 closed defect (duplicate)

AttributeError: 'unicode' object has no attribute 'base'

Reported by: fr00d Owned by: doki_pen
Priority: normal Component: AnnouncerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

I just got this error in trac.log when try to send email announcement for ticket change. Can somebody tell me what wents wrong?

2011-11-16 09:51:59,254 Trac[ticket_email] ERROR: 
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/TracAnnouncer-0.11.1_r10458-py2.6.egg/announcerplugin/formatters/ticket_email.py", line 190, in _format_html
    temp = formatter.generate(True)
  File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1452, in generate
    escape_newlines)
  File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1240, in format
    result = re.sub(self.wikiparser.rules, self.replace, line)
  File "/usr/lib64/python2.6/re.py", line 151, in sub
    return _compile(pattern, 0).sub(repl, string, count)
  File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1158, in replace
    replacement = self.handle_match(fullmatch)
  File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 1154, in handle_match
    return internal_handler(match, fullmatch)
  File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 540, in _lhref_formatter
    return self._make_lhref_link(match, fullmatch, rel, ns, target, label)
  File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 581, in _make_lhref_link
    fullmatch)
  File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 607, in _make_link
    return self._make_ext_link(ns + ':' + target, label)
  File "/usr/lib/python2.6/site-packages/trac/wiki/formatter.py", line 660, in _make_ext_link
    (self.req or self.env).abs_href.base
AttributeError: 'unicode' object has no attribute 'base'

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Did you email comment contain a URL? It looks like this is a duplicate of #8923.

Add Comment

Modify Ticket

Action
as closed The owner will remain doki_pen.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.