Modify

Opened 3 years ago

Closed 2 years ago

#9567 closed defect (invalid)

date picker gets basics wrong

Reported by: info@… Owned by: rjollos
Priority: high Component: DateFieldPlugin
Severity: major Keywords: datepicker
Cc: rjollos, coling Trac Release: 0.12

Description

See attached screenshot.

Friday - Monday - Thursday - Sunday - Wednesday - Saturday - Tuesday

You have an interesting sequence of weekdays. :-)

Attachments (1)

datepicker.png (10.8 KB) - added by anonymous 3 years ago.

Download all attachments as: .zip

Change History (11)

Changed 3 years ago by anonymous

comment:1 Changed 3 years ago by rjollos

  • Cc rjollos added

I encountered this problem. I think it was due to a conflict with another plugin. If I remember correctly, it was the WorkLogPlugin that caused a problem. Could you post your list of installed plugin?

comment:2 Changed 3 years ago by rjollos

  • Owner changed from doki_pen to rjollos
  • Status changed from new to assigned

comment:3 follow-up: Changed 3 years ago by anonymous

Trac 0.12.2

ContextMenuPlugin 0.1
ExcelDownloadPlugin 0.12.0.1
FootNoteMacro 1.03-r10434
graphviz 0.7.5
RedirectsPlugin 0.1
SvnAuthzAdminPlugin 0.2
timingandestimationplugin 1.1.9
TracAccountManager 0.3.2
TracCodeReview 1.1a
TracCustomFieldAdmin 0.2.6-r10460
TracDateField 1.0.2-r10435
TracIncludeMacro 2.1
TracMasterTickets 3.0.2
TracMetrixPlugin 0.1.8
TracStats 0.4
TracTags 0.7dev-r10639
TracTicketChangelogPlugin 0.1
TracTocMacro 11.0.0.3
TracWorkflowAdmin 0.12.0.1
worklog 0.2

=> Interesting thing is, when I create a ticket, I have a DIFFERENT datepicker than when I modify a ticket. Definitely 2 code paths. The datepicker when creating is ok. This datepicker was when modifying.

comment:4 in reply to: ↑ 3 Changed 3 years ago by rjollos

Replying to anonymous:

=> Interesting thing is, when I create a ticket, I have a DIFFERENT datepicker than when I modify a ticket. Definitely 2 code paths. The datepicker when creating is ok. This datepicker was when modifying.

Yeah, those are the same symptoms I had. Please try disabling WorkLogPlugin and see if the dates are correct then. Assuming that is the case, I'm not sure what the fix is, but it has to do with conflicting versions of the jquery datepicker.

comment:5 Changed 3 years ago by anonymous

I can confirm it - back and forth.

Disabling worklog plugin (0.2) makes the weird datepicker go away when modifying a ticket. Enabling worklog makes it reappear. Ok. So whatever the fix is, we know at least the cause.

comment:6 Changed 3 years ago by rjollos

Let's see if we can accomplish a fix by an upgrade of datepicker for the DateFieldPlugin. Are you available to do some testing?

comment:7 follow-up: Changed 3 years ago by anonymous

sure. I can't promise ultra-short response times, but basically I'm willing to help with that.

comment:8 in reply to: ↑ 7 Changed 3 years ago by rjollos

Replying to anonymous:

sure. I can't promise ultra-short response times, but basically I'm willing to help with that.

Okay, thanks. I'll see if I can get something uploaded by the weekend.

comment:9 Changed 3 years ago by rjollos

  • Cc coling added

DateFieldPlugin is using jQuery UI 1.8.16, which is the latest version. It looks like our best option might be to port the WorkLogPlugin to using jQuery UI as well. I can probably get to that eventually, but it won't happen for weeks to months. I've cc'ed the author of the WorkLogPlugin to see if he has any comments.

comment:10 Changed 2 years ago by rjollos

  • Resolution set to invalid
  • Status changed from assigned to closed

I think a ticket should be filed against the WorkLogPlugin to suggest an upgrade of the jQuery UI. The author of that plugin has offered me commit access, so I can probably take care of that within the next few months. I'm closing this ticket and I'll open a new one against the WorkLogPlugin.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.