Modify

Opened 2 years ago

Closed 23 months ago

#9707 closed defect (worksforme)

WYSIWYG editor not displayed

Reported by: rajnesh.siwal@… Owned by: jun66j5
Priority: normal Component: TracWysiwygPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

tracwysiwygplugin/0.12/ has been installed on Trac.
It has been enabled in [components] sections :-

[components]
tracwysiwyg.* = enabled
tracwysiwyg.wysiwygmodule = enabled

Still, I cannot see the radio button to switch between TextArea and WYSIWYG editor.
I am unable to switch to tracwysiwyg.
Please suggest.

Attachments (1)

wysisuget.png (33.9 KB) - added by rajnesh.siwal@… 2 years ago.
snapshot

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by rajnesh.siwal@…

snapshot

comment:1 Changed 2 years ago by jun66j5

  • Please tell me which version of browser you're using.
  • Check javascript console in your browser.
  • Check log/trac.log in your tracenv.

comment:2 Changed 2 years ago by rajnesh.siwal@…

Tried on Firefox 9.0.1, FAILS
Tried on Internet Explorer 9, FAILS

Trac version

[rsiwal@ldaptest ~]$ rpm -qa|grep -i trac
trac-0.12-2.el5.rf
2012-01-18 22:44:54,871 Trac[svn_fs] DEBUG: Subversion bindings imported
2012-01-18 22:44:54,921 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 438, in process_request
    for dir in [os.path.normpath(dir[1]) for dir
  File "build/bdist.linux-x86_64/egg/sequencediagram/macro.py", line 66, in get_htdocs_dirs
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 799, in resource_filename
    return get_provider(package_or_requirement).get_resource_filename(
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 1229, in get_resource_filename
    return self._extract_resource(manager, zip_path)
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 1240, in _extract_resource
    zip_stat = self.zipinfo[zip_path]
KeyError: 'sequencediagram/htdocs'
2012-01-18 22:44:58,317 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/tracwysiwyg/wysiwyg.js'">
2012-01-18 22:44:58,320 Trac[chrome] DEBUG: Prepare chrome data for request
2012-01-18 22:44:58,323 Trac[session] DEBUG: Retrieving session for ID 'rsiwal'
2012-01-18 22:44:58,325 Trac[api] DEBUG: action controllers for ticket workflow: ['ConfigurableTicketWorkflow']
2012-01-18 22:44:58,330 Trac[svn_fs] DEBUG: Subversion bindings imported
2012-01-18 22:44:58,335 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 438, in process_request
    for dir in [os.path.normpath(dir[1]) for dir
  File "build/bdist.linux-x86_64/egg/sequencediagram/macro.py", line 66, in get_htdocs_dirs
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 799, in resource_filename
    return get_provider(package_or_requirement).get_resource_filename(
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 1229, in get_resource_filename
    return self._extract_resource(manager, zip_path)
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 1240, in _extract_resource
    zip_stat = self.zipinfo[zip_path]
KeyError: 'sequencediagram/htdocs'
2012-01-18 22:45:01,614 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/tracwysiwyg/wysiwyg-load.js'">
2012-01-18 22:45:01,618 Trac[chrome] DEBUG: Prepare chrome data for request
2012-01-18 22:45:01,622 Trac[session] DEBUG: Retrieving session for ID 'rsiwal'
2012-01-18 22:45:01,624 Trac[api] DEBUG: action controllers for ticket workflow: ['ConfigurableTicketWorkflow']
2012-01-18 22:45:01,631 Trac[svn_fs] DEBUG: Subversion bindings imported
2012-01-18 22:45:01,636 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 513, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/trac/web/chrome.py", line 438, in process_request
    for dir in [os.path.normpath(dir[1]) for dir
  File "build/bdist.linux-x86_64/egg/sequencediagram/macro.py", line 66, in get_htdocs_dirs
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 799, in resource_filename
    return get_provider(package_or_requirement).get_resource_filename(
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 1229, in get_resource_filename
    return self._extract_resource(manager, zip_path)
  File "/usr/lib/python2.4/site-packages/pkg_resources.py", line 1240, in _extract_resource
    zip_stat = self.zipinfo[zip_path]
KeyError: 'sequencediagram/htdocs'
2012-01-18 22:45:05,973 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/folder.png'">
2012-01-18 22:45:05,977 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/expander_normal.png'">
2012-01-18 22:45:05,985 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/asc.png'">
2012-01-18 22:45:06,007 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/changeset.png'">
2012-01-18 22:45:08,111 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/expander_normal_hover.png'">
2012-01-18 22:45:11,080 Trac[main] DEBUG: Dispatching <Request "GET '/browser/gatewayServer'">
2012-01-18 22:45:11,082 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/loading.gif'">
2012-01-18 22:45:11,083 Trac[api] INFO: Synchronized '' repository in 0.00 seconds
2012-01-18 22:45:11,084 Trac[session] DEBUG: Retrieving session for ID 'rsiwal'
2012-01-18 22:45:11,092 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/expander_open_hover.png'">
2012-01-18 22:45:11,094 Trac[chrome] DEBUG: Prepare chrome data for request
2012-01-18 22:45:11,701 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/expander_open.png'">
2012-01-18 22:45:19,726 Trac[main] DEBUG: Dispatching <Request "GET '/browser/gatewayServer/trunk'">
2012-01-18 22:45:19,786 Trac[svn_fs] DEBUG: Subversion bindings imported
2012-01-18 22:45:19,790 Trac[api] INFO: Synchronized '' repository in 0.06 seconds
2012-01-18 22:45:19,791 Trac[session] DEBUG: Retrieving session for ID 'rsiwal'
2012-01-18 22:45:19,795 Trac[api] DEBUG: action controllers for ticket workflow: ['ConfigurableTicketWorkflow']
2012-01-18 22:45:19,934 Trac[chrome] DEBUG: Prepare chrome data for request
2012-01-18 22:45:20,723 Trac[main] DEBUG: Dispatching <Request "GET '/chrome/common/file.png'">

comment:3 Changed 2 years ago by jun66j5

  • Priority changed from high to normal

Hmmm, I tested with trac 0.12 and tracwysiwyg 0.12.0.4 now, in my environment. And, works fine for me! I think the issue is a installation problem.

Disable the other plugins than tracwysiwyg and try again. If it still doesn't work, could you attach conf/trac.ini and log/trac.log?

comment:4 Changed 2 years ago by rajnesh.siwal@…

[components]
acct_mgr.admin.accountmanageradminpage = enabled
acct_mgr.api.accountmanager = enabled
acct_mgr.db.sessionstore = enabled
acct_mgr.htfile.abstractpasswordfilestore = enabled
acct_mgr.htfile.htdigeststore = enabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.http.httpauthstore = enabled
acct_mgr.pwhash.htdigesthashmethod = enabled
acct_mgr.pwhash.htpasswdhashmethod = enabled
acct_mgr.svnserve.svnservepasswordstore = enabled
acct_mgr.web_ui.accountmodule = enabled
acct_mgr.web_ui.loginmodule = enabled
acct_mgr.web_ui.registrationmodule = enabled
gchartplugin.charting.gchart = enabled
sequencediagram.* = enabled
tracmetrixplugin.* = enabled
tractoc.* = enabled
tracwysiwyg.* = enabled
tracwysiwyg.wysiwygmodule = enabled
webadmin.* = enabled
yuml.* = enabled

components section is as above.
I am unable to attach the complete ini file

comment:5 Changed 2 years ago by rjollos

  • Description modified (diff)

comment:6 follow-up: Changed 23 months ago by anonymous

Same here, using trac 0.12.3

Getting

2012-05-28 18:24:41,856 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "build/bdist.linux-x86_64/egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 463, in process_request
    in provider.get_htdocs_dirs() or []
  File "build/bdist.linux-x86_64/egg/tracwysiwyg/__init__.py", line 31, in get_htdocs_dirs
    return [('tracwysiwyg', resource_filename(__name__, 'htdocs'))]
  File "/opt/trac-0.12.3-0/python/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 882, in resource_filename
    self, resource_name
  File "/opt/trac-0.12.3-0/python/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 1352, in get_resource_filename
    return self._extract_resource(manager, zip_path)
  File "/opt/trac-0.12.3-0/python/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 1363, in _extract_resource
    zip_stat = self.zipinfo[zip_path]
KeyError: 'tracwysiwyg/htdocs'

comment:7 in reply to: ↑ 6 Changed 23 months ago by jun66j5

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to anonymous:

File "/opt/trac-0.12.3-0/python/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 1363, in _extract_resource

zip_stat = self.zipinfo[zip_path]

KeyError: 'tracwysiwyg/htdocs'

Installation problem.

TracWysiwyg-0.12.0.4-*.egg certainly has tracwysiwyg/htdocs.

jun66j5@gotanda:366$ ~/venv/trac-0.12/bin/python setup.py bdist_egg
running bdist_egg
running egg_info
writing TracWysiwyg.egg-info/PKG-INFO
...
creating dist
creating 'dist/TracWysiwyg-0.12.0.4-py2.4.egg' and adding 'build/bdist.linux-i686/egg' to it
removing 'build/bdist.linux-i686/egg' (and everything under it)
jun66j5@gotanda:367$ unzip -l dist/TracWysiwyg-0.12.0.4-py2.4.egg | grep htdocs
       85  01-19-12 02:08   tracwysiwyg/htdocs/wysiwyg-load.js
      166  01-19-12 02:08   tracwysiwyg/htdocs/editor.css
     4492  01-19-12 02:08   tracwysiwyg/htdocs/wysiwyg.css
     4848  01-19-12 02:08   tracwysiwyg/htdocs/toolbar.png
   144802  03-09-12 15:50   tracwysiwyg/htdocs/wysiwyg.js

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from jun66j5. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.