Modify

Opened 3 years ago

Closed 2 weeks ago

#9855 closed defect (wontfix)

[PATCH] UI conflict with TimingAndEstimation

Reported by: shesek Owned by: CuriousCurmudgeon
Priority: normal Component: BatchModifyPlugin
Severity: normal Keywords:
Cc: bobbysmith007 Trac Release: 0.12

Description

The TimingAndEstimationPlugin adds an <tfoot> to the table with some totals, which the BatchModify plugin modifies. This patch fixes it by specifically looking for elemehts in <thead> and <tobdy> only:

  • batchmod/htdocs/js/batchmod.js

    ndex: batchmod/htdocs/js/batchmod.js
     
    8989     
    9090    //Add a new column with checkboxes for each ticket. 
    9191    //Selecting a ticket marks it for inclusion in the batch.  
    92     $("table.listing tr td.id").each(function() { 
     92    $("table.listing tbody tr td.id").each(function() { 
    9393        tId=$(this).text().substring(1);  
    9494        $(this).before('<td><input type="checkbox" name="selectedTicket" class="batchmod_selector" value="'+tId+'"/></td>'); 
    9595    }); 
    9696 
    9797    //Add a checkbox at the top of the column to select ever ticket in the group. 
    98     $("table.listing tr th.id").each(function() {  
     98    $("table.listing thead tr th.id").each(function() {  
    9999        $(this).before('<th class="batchmod_selector"><input type="checkbox" name="batchmod_toggleGroup" /></th>'); 
    100100    }); 
    101101 

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by rjollos

Duplicate of #8368, but the lower numbered ticket was closed because this one has a patch.

comment:2 Changed 2 years ago by rjollos

  • Cc bobbysmith007 added

This patch has not been incorporated into the BatchModifyPlugin in Trac 0.13dev.

(cc'ing the TimingAndEstimationPlugin author since he may be able to head off a potential future compatibility problem between his plugin and Trac 0.13)

comment:3 Changed 2 weeks ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

The plugin is deprecated since it has been integrated to the Trac core for 1.0. Upgrade to Trac 1.0 and uninstall this plugin to get the latest functionality. Enhancement requests can be directed to Trac.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.