Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#9865 closed defect (fixed)

Corrupt database after activation of Plugin

Reported by: martin.fernholz@… Owned by: seccanj
Priority: normal Component: TestManagerForTracPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

I installed TracGenericClass 1.1.1, TracGenericWorkflow 1.0.3 and activate them. Then I updated the database and restarted the Apache2. After this I installed TestManager 1.4.9 and activate it. Than i had to upgrade the TRAC Env. There was no Error-Message and the Debug-Log looks good (see attached file). But when I restartet the Apache2 and open the Trac in my browser I have still the message "Database need to be upgraded".
What went wrong?

Attachments (1)

trac_debug.log (61.8 KB) - added by martin.fernholz@… 2 years ago.
TRAC debug log

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by martin.fernholz@…

TRAC debug log

comment:1 Changed 2 years ago by seccanj

Hi Martin,
you're right, the log looks clean...

I've seen a similar problema in the past, and it was not caused by test manager but by another installed plugin.

I suggest to disable any other plugin you have and just enable the TracGenericClass, TracGenericWorkflow and TestManager, and restart apache (still with debug enabled).

Let me know how it goes.

Ciao,
Roberto

comment:2 Changed 2 years ago by martin.fernholz@…

  • Resolution set to fixed
  • Status changed from new to closed
  • Trac Release changed from 0.11 to 0.12

Hi Roberto, the database was not the problem. Upgrading the Trac-Env caused a "chown" on the trac.ini to root:www. I changed it back to wwwrun:www and everything works fine.

Thx for your support.

Martin

comment:3 Changed 2 years ago by seccanj

No problem. Glad you solved it :D

FYI, I've just fixed #9758 and will release soon.

Ciao,
Roberto

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from seccanj. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.