Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#9955 closed defect (fixed)

'comma' is not processed correctly

Reported by: tom.ghyselinck@… Owned by: rjollos
Priority: normal Component: PlantUmlMacro
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

The following code shows no @startuml found (see plantuml.png)

{{{
#!PlantUML
@startuml
note right of test : a, b
@enduml
}}}

while

{{{
#!PlantUML
@startuml
note right of test : a\, b
@enduml
}}}

shows the correct image (see plantuml2.png)

Attachments (2)

plantuml.png (1.2 KB) - added by anonymous 2 years ago.
invalid parsing
plantuml2.png (1.1 KB) - added by anonymous 2 years ago.
correctly parsed when escaping ,

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by anonymous

invalid parsing

Changed 2 years ago by anonymous

correctly parsed when escaping ,

comment:1 Changed 2 years ago by rjollos

  • Owner changed from airadier to rjollos
  • Status changed from new to assigned

Thank you for the report. I'm glad to know someone is using the plugin! I'll see if I can get this fixed today.

comment:2 Changed 2 years ago by rjollos

Also found that

{{{
#!PlantUML
}}}

Would result in a list index out of range error, rather than the proper No UML text defined! message.

comment:3 Changed 2 years ago by rjollos

[11476] by rjollos on 04/11/12 23:54:51:

Refs #9955: FIX: If no PlantUML markup was defined, a list index out of range error would result, rather than the No UML text defined! message that was intended.

comment:4 Changed 2 years ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [11478]) Fixes #9955: Commas in content were being escaped with backslashes by parse_args in the Trac API.

comment:5 Changed 2 years ago by rjollos

[11478] seems to fix the issue. Please reopen if that is not the case for you.

comment:6 Changed 2 years ago by anonymous

Thanks!

Working fine now!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.