Modify

Opened 2 years ago

Closed 15 months ago

#9960 closed defect (duplicate)

UnicodeDecodeError: 'utf8' codec can't decode byte 0xfc in position 20: invalid start byte

Reported by: alegz@… Owned by: hvr
Priority: normal Component: GitPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a GET operation on /changeset, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'new': u'79cf28fad96b103e92d1412281a965f6ef3a6ecb',
 'new_path': u'/DreamMealDeal_git/application/controllers/default.class.php',
 'old': u'79cf28fad96b103e92d1412281a965f6ef3a6ecb',
 'old_path': u'/DreamMealDeal_git/application/controllers/default.class.php'}

User agent: Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

System Information

Trac 0.12.3
Babel 0.9.6
Genshi 0.6
GIT 1.7.9.2
Mercurial 2.1
psycopg2 2.4.4
Pygments 1.5
Python 2.7.2 (default, Jan 31 2012, 13:19:49)
[GCC 4.6.2 20120120 (prerelease)]
setuptools 0.6
jQuery 1.4.4

Enabled Plugins

TracGit 0.12.0.5dev
TracMercurial 0.12.0.28

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.7/site-packages/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.7/site-packages/trac/versioncontrol/web_ui/changeset.py", line 352, in process_request
    self._render_html(req, repos, chgset, restricted, xhr, data)
  File "/usr/lib/python2.7/site-packages/trac/versioncontrol/web_ui/changeset.py", line 581, in _render_html
    for old_node, new_node, kind, change in get_changes():
  File "/usr/lib/python2.7/site-packages/trac/versioncontrol/web_ui/changeset.py", line 395, in get_changes
    for npath, kind, change, opath, orev in chgset.get_changes():
  File "/usr/lib/python2.7/site-packages/tracext/git/git_fs.py", line 655, in get_changes
    self.repos.git.diff_tree(parent, self.rev, find_renames=True):
  File "/usr/lib/python2.7/site-packages/tracext/git/PyGIT.py", line 862, in diff_tree
    yield __chg_tuple()
  File "/usr/lib/python2.7/site-packages/tracext/git/PyGIT.py", line 854, in __chg_tuple
    chg[5] = self._fs_to_unicode(chg[5])
  File "/usr/lib/python2.7/site-packages/tracext/git/PyGIT.py", line 237, in <lambda>
    self._fs_to_unicode = lambda s: s.decode(git_fs_encoding)
  File "/usr/lib/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xfc in position 20: invalid start byte

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by rjollos

  • Component changed from SELECT A HACK to GitPlugin
  • Owner set to hvr

comment:2 Changed 15 months ago by jun66j5

  • Resolution set to duplicate
  • Status changed from new to closed

A duplicate of #8087.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hvr. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.