wiki:ForceCommentPlugin

Force-comment plugin

Description

This is a simple plugin that requires a user to enter a comment when making changes to a wiki page.

Current version has some user configurable options:

option name type default value
min_comment_length integer 10
cosmetic_change_comment string "cosmetic"
error_text string "A full comment must be supplied for this change,
or use " <cosmetic_change_comment> " if no actual informational content has changed."

If you already use it, consider an upgrade before/when upgrading Trac from 0.11, since there was a small bug hitting trac-0.12dev anywhere after r9284.
The fixed version was tested with trac-0.12dev-r9443 and works, but lacks i18n support introduced to Trac in this release.

Download

Download the zipped source from here.

Source

You can check out ForceCommentPlugin from here using Mercurial.

Example

Simply install the hack, sit back, and BE AMAZED.

(see README for installation instructions)

Author/Contributors

Author: edgimar
Maintainer: edgimar
Contributors: hasienda
License: 3-Clause BSD

Last modified 2 years ago Last modified on Jul 4, 2012 12:54:53 AM