Changes between Initial Version and Version 6 of Ticket #13543


Ignore:
Timestamp:
Apr 3, 2019, 6:43:48 PM (3 years ago)
Author:
Ryan J Ollos
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #13543

    • Property Status changed from new to closed
    • Property Owner osimons deleted
    • Property Resolution changed from to cantfix
  • Ticket #13543 – Description

    initial v6  
    11==== How to Reproduce ====
    22
    3 (1) Configure multiple custom fields ("dev", "sales", "users" in this case with possible values "", "S", "M", "L" and "XL" for each field).
    4 
    5 (2) Open /query and build a custom query where you try to select multiple values for at least two custom fields and press "Update"
    6 
    7 (3) Select the URL in the browser address bar, copy and paste it into another browser window.
     31. Configure multiple custom fields ("dev", "sales", "users" in this case with possible values "", "S", "M", "L" and "XL" for each field).
     41. Open /query and build a custom query where you try to select multiple values for at least two custom fields and press "Update"
     51. Select the URL in the browser address bar, copy and paste it into another browser window.
    86
    97Expected result:
     
    1917The problem seems to be caused by incorrect caching when query with multiple custom fields is done via GET. If I build the same query using custom query UI and press "Update" button, the query runs fine. The query also seems to work once if the same query has not been run in a while.
    2018
    21 The cause is probably similar to https://trac.edgewall.org/ticket/13068 but this is about Filters because the problem still appears even with only Summary column selected.
     19The cause is probably similar to t:#13068 but this is about Filters because the problem still appears even with only Summary column selected.
    2220
    2321Note: trac report bug button automatically selected XmlRpcPlugin as the component for this ticket, but I think it's not the correct one. I believe the problem is in core Trac ticket query implementation. I have left the Component field in this bug as-is because I'm not sure how this should be handled here.