Opened 13 years ago

Closed 7 years ago

#8837 closed defect (worksforme)

does not work on 0.12

Reported by: yenik Owned by: Franz
Priority: normal Component: BudgetingPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12


precompiled egg installed via GUI does not work. It gets installed, but when I try to display existing ticket, it throws following error :

Trac detected an internal error:

OperationalError: unrecognized token: ":"

Attachments (0)

Change History (10)

comment:1 Changed 13 years ago by anonymous

Most recent call last:

File "build/bdist.linux-i686/egg/trac/web/", line 511, in _dispatch_request
File "build/bdist.linux-i686/egg/trac/web/", line 258, in dispatch
File "build/bdist.linux-i686/egg/trac/web/", line 840, in render_template
  stream |= self._filter_stream(req, method, filename, stream, data)
File "build/bdist.macosx-10.6-universal/egg/genshi/", line 132, in __or__
  return Stream(_ensure(function(self)), serializer=self.serializer)
File "build/bdist.linux-i686/egg/trac/web/", line 991, in inner
File "build/bdist.win32/egg/ticketbudgeting/", line 286, in filter_stream
File "build/bdist.win32/egg/ticketbudgeting/", line 739, in create_table
File "build/bdist.win32/egg/ticketbudgeting/", line 762, in create_reports
  raise e

comment:2 Changed 13 years ago by Franz

This occurs when creating default report (see; there should be some more log-infos. This might be probably an encoding problem.

Are you using Trac 0.12 or 0.11? Have you tried to compile it yourself?

comment:3 Changed 13 years ago by Xeross

Trac Release: 0.110.12

I'm experiencing the same problem, I compiled Trac and BudgetingPlugin myself.

I'll look into the logs tomorrow, as I'm out of time now.

comment:4 Changed 13 years ago by anonymous

Any news on a fix for this? Or a workaround?

comment:5 Changed 13 years ago by Franz

No news, as I don't know what exactly the problem is. There might be a few issues, which might cuase the problem:

  • if you you use Python 2.4 or 2.5 it might not be compiled or installed, see #8839
  • in the SQL statement is an German umlaut, which migh cause some problems, see #9517; if you remove the words with umlauts, it might work

Note that there is already a discussion going on how to solve localized reports, see Google-Groups

comment:6 Changed 12 years ago by anonymous

exactly the same error:-(

comment:7 Changed 12 years ago by anonymous

rhel-6.3 :

Trac	0.12.3
Babel	0.9.4
Genshi	0.6
mod_python	3.3.1
pysqlite	2.4.1
Python	2.6.6 (r266:84292, Jun 18 2012, 21:49:31) [GCC 4.4.6 20110731 (Red Hat 4.4.6-3)]
pytz	2010h
setuptools	0.6
SQLite	3.6.20
Subversion	1.6.11 (r934486)
jQuery	1.4.2


and the error:

File "/usr/lib/python2.6/site-packages/trac/web/", line 525, in _dispatch_request
File "/usr/lib/python2.6/site-packages/trac/web/", line 267, in dispatch
File "/usr/lib/python2.6/site-packages/trac/web/", line 841, in render_template
File "/usr/lib/python2.6/site-packages/Genshi-0.6-py2.6.egg/genshi/", line 132, in __or__
File "/usr/lib/python2.6/site-packages/trac/web/", line 997, in inner
File "/usr/lib/python2.6/site-packages/ticketbudgeting/", line 287, in filter_stream
File "/usr/lib/python2.6/site-packages/ticketbudgeting/", line 759, in create_table
File "/usr/lib/python2.6/site-packages/ticketbudgeting/", line 782, in create_reports

Code fragment:

777	                db.commit()
778	      "[INIT reports] successfully created report with id %s" % report[0])
779	            except Exception, e:
780	                self.log.error("[INIT reports] Error executing SQL Statement \n %s" % e)
781	                db.rollback();
782	                raise e
783	            finally:
784	                db.close()
787	    def get_col_list(self, ignore_cols=None):

Local variables:

Name	Value
db	<trac.db.pool.PooledConnection object at 0x7f6febbe5d70>
descr	u'report_description_90'
e	OperationalError('near ".": syntax error',)
myCursor	<trac.db.util.IterableCursor object at 0x7f6febc2bbd0>
report	(90, 'report_title_90', 'report_description_90', u'SELECT, t.summary, ...
self	<ticketbudgeting.ticketbudgeting.TicketBudgetingView object at ...
sql	u'INSERT INTO report (id, author, title, query, description)  VALUES(90, ...

comment:8 Changed 12 years ago by Levente Farkas

any other info needed?

comment:9 Changed 12 years ago by Franz

Sorry, no idea. I just guess it is because of using SQLite. We use the latest BudgetingPlugin with postgres 8.4, Trac 1.0, and Python 2.6.5. In that environment it works fine.

For Trac 0.12 please use Budgeting_Plugin-0.5.a4-py2.6.egg or build it from source by using 0.12-tag

Version 0, edited 12 years ago by Franz (next)

comment:10 Changed 7 years ago by Ryan J Ollos

Resolution: worksforme
Status: newclosed

The minimum requirement for the latest BudgetingPlugin is Trac 1.0.

There are some remaining string interpolation issues on SQL statements, which will be fixed in #9517.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain Franz.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.