Modify

Opened 2 years ago

Closed 3 months ago

#10257 closed enhancement (wontfix)

Incompatible with TracMathJax (possibly TracMath)

Reported by: fommil Owned by: jun66j5
Priority: low Component: TracWysiwygPlugin
Severity: normal Keywords:
Cc: kisielk Trac Release: 0.11

Description

Before we get started, I'm not suggesting that the math should be WYSIWYG ;-)

However, the WYSIWYG should completely ignore everything inside a math area. Currently the WYSIWYG fails on these simple test cases in two ways:

Here is an inline equation: \( y = x^2 \)

Here is a block equation: $$ y = x^2 $$

Firstly, it tries to render everything after the caret as superscript. Secondly, when converting back to plain text mode, the plugin is adding an extra caret at the end of each line containing the mathematics.

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by fommil

  • Cc kisielk added; anonymous removed

comment:2 Changed 2 years ago by jun66j5

  • Priority changed from normal to low
  • Type changed from defect to enhancement

Not a bug.

WYSIWYG editor doesn't handle any processor in code block, e.g. #!div, #!span, #!rst, #!textile and #latex.

comment:3 Changed 2 years ago by jun66j5

And, the plugin cannot handle other than TracWiki syntax.

comment:4 Changed 2 years ago by fommil

It's in blockcode so you can see what is being entered - on a wiki page the user wouldn't put it in block.

comment:5 Changed 2 years ago by fommil

Can you perhaps liaise with the MathJax author (CCd) to come up with something that works then, please? Mutually exclusive WYSIWYG and Math support is a show stopper for my projects.

comment:6 Changed 3 months ago by jun66j5

  • Resolution set to wontfix
  • Status changed from new to closed

I have no plan to fix it. This plugin only understand TracWiki.

Add Comment

Modify Ticket

Action
as closed The owner will remain jun66j5.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.