Modify

Opened 23 months ago

Closed 23 months ago

Last modified 23 months ago

#10290 closed defect (duplicate)

STractistics Plugin is not displayed in the menu bar

Reported by: kstyanos@… Owned by: rjollos
Priority: high Component: StractisticsPlugin
Severity: major Keywords: STractistics, menu bar
Cc: Trac Release: 0.11

Description

Please, help me Plugin STractistics-0.5.0b-py2.6.egg already installed but it is not displayed in the menu bar. Setuptools is properly installed, the plugin is enabled, I have the correct version of the Python egg and I don't know why did not it work? Thanks for your help.

Attachments (0)

Change History (9)

comment:1 Changed 23 months ago by rjollos

Please turn on t:TracLogging and search the logs for messages related to StractisticsPlugin.

comment:2 Changed 23 months ago by rjollos

If I had to guess at your problem, you probably don't have ClearSilver installed.

comment:3 follow-up: Changed 23 months ago by kstyanos@…

System Information

Trac: 0.11.6
Python: 2.6.4 (r264:75708, Oct 26 2009, 08:23:19) [MSC v.1500 32 bit (Intel)]
setuptools: 0.6c12
SQLite: 3.5.9
pysqlite: 2.4.1
Genshi: 0.5.1
Subversion: 1.6.6 (r40053)
jQuery: 1.2.6

But I think that ClearSilver is not necessary, because only is available for python 2.5. Am I right? or I must install it with python 2.6. Thanks for your help again.

comment:4 Changed 23 months ago by kstyanos@…

I forgot to let you know that my Operating System is Microsoft Windows 7 Enterprise with Service Pack 1. Thanks!.

comment:5 Changed 23 months ago by kstyanos@…

  • Resolution set to fixed
  • Status changed from new to closed

The problem is resolved. Although the requirements says that If your python < 2.6, it requires simplejson in this case my software was python 2.6.4 and I was necessary to install simplejson 2.6.1. With this STractistics was displayed in the menu bar. This error was observed through the file trac.log. Thanks a lot for all.

comment:6 Changed 23 months ago by rjollos

I'm guessing that the author was assuming that since json was added to the Python core in 2.6, simplejson should not be needed. I think we can probably modify the source to use json when it is available.

comment:7 Changed 23 months ago by rjollos

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Changed 23 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #9086. Thank you for the detailed investigation!

comment:9 in reply to: ↑ 3 Changed 23 months ago by rjollos

Replying to kstyanos@gmail.com:

But I think that ClearSilver is not necessary, because only is available for python 2.5. Am I right? or I must install it with python 2.6. Thanks for your help again.

You are right, that ClearSilver isn't required. The 0.11 branch and trunk have been ported to Genshi.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.