Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#10427 closed defect (fixed)

ScreenShotPaste doesn't work with trac 1.0

Reported by: craig.fisher@… Owned by: seccanj
Priority: normal Component: ScreenshotPastePlugin
Severity: blocker Keywords:
Cc: Trac Release: 1.0

Description

Following upgrade from trac 0.12 to trac 1.0, paste the clipboard function still works, but when you try to 'Send the Screenshot', it brings up a pop-up box with HTML for the whole page, with an error "Missing or invalid form token. Do you have cookies enabled" buried in the middle of it.

Have attached the main section of the HTML in case it's useful. Happy to help with any debug info - but not a python person so you need to be gentle...

Attachments (1)

screenshotpasteplugintrac10.PNG (69.7 KB) - added by craig.fisher@… 2 years ago.
ScreenshotPastePlugin fail on Trac 1.0

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by craig.fisher@…

ScreenshotPastePlugin fail on Trac 1.0

comment:1 Changed 2 years ago by seccanj

  • Status changed from new to assigned

Hi Craig, sorry I'm only replying after so long.

I've been very busy at work, and I gave precedence to updating the Test Manager plugin to be compatible with Trac 1.0.

I hope I'll find some time to work on this one pretty soon.

Stay tuned :D

Ciao, Roberto

comment:2 Changed 2 years ago by seccanj

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with 0.1.2.

Get it here!

comment:3 Changed 2 years ago by anonymous

Excellent - many thanks! Have installed, tested and re-enabled it for use.

Regards, -Craig

Add Comment

Modify Ticket

Action
as closed The owner will remain seccanj.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.