Modify

Opened 2 years ago

Closed 23 months ago

#10705 closed defect (worksforme)

Empty milestones causes new ticket form to not populate project specific fields

Reported by: anonymous Owned by: crossroad
Priority: normal Component: SimpleMultiProjectPlugin
Severity: minor Keywords:
Cc: Trac Release: 1.0

Description

To reproduce:

1) Setup a project with project versions and/or project components.
2) Remove all milestones.
3) Attempt to create a new ticket.

After selecting the project (new ticket form), version and components will not be populated. Repeating the process with at least one milestone, the project specific version and components are populated correctly.

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by anonymous

  • Trac Release set to 1.0

comment:2 Changed 23 months ago by falkb

  • Resolution set to worksforme
  • Status changed from new to closed

I tried to reproduce with the latest SVN version but it works for me:

  1. created a project "test" on Admin page
  2. created one version "1.0" on Roadmap page
  3. created one milestone "M1" on Roadmap page
  4. called "New Ticket" => after chosing "test" from the project combobox, "1.0" and "M1" were available as expected
  5. deleted "M1" on Roadmap page
  6. called "New Ticket" => after chosing "test" from the project combobox, "1.0" was still available and "M1" was not, as expected

If you want to reopen this ticket, please, with more details and a valid email address or login for discussing.

Add Comment

Modify Ticket

Action
as closed The owner will remain crossroad.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.