Modify

#10938 closed defect (duplicate)

AttributeError: hdf

Reported by: bkalbfus@… Owned by: sambloomquist
Priority: normal Component: ScrumBurndownPlugin
Severity: blocker Keywords:
Cc: Trac Release: 1.0

Description

How to Reproduce

While doing a GET operation on /burndown, Trac issued an internal error.

This was on a new upgrade of the default "Project" that comes with trac. I was testing this plugin before installing into my production environment.

Request parameters:

{}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

System Information

Trac 1.0
Babel 0.9.6
Genshi 0.6 (without speedups)
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
pysqlite 2.6.3
Python 2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit (Intel)]
setuptools 0.6c11
SQLite 3.7.6.2
Subversion 1.7.4 (r1295709)
jQuery 1.7.2

Enabled Plugins

timingandestimationplugin 1.3.0b
tracburndown 1.9.2dev

Python Traceback

Traceback (most recent call last):
  File "c:\users\bkalbfus\appdata\local\temp\2\easy_install-jhecks\Trac-1.0-py2.7-win32.egg.tmp\trac\web\main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "c:\users\bkalbfus\appdata\local\temp\2\easy_install-jhecks\Trac-1.0-py2.7-win32.egg.tmp\trac\web\main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "build\bdist.win32\egg\burndown\burndown.py", line 155, in process_request
    data['milestones'] = req.hdf['milestones'] = milestones
  File "c:\users\bkalbfus\appdata\local\temp\2\easy_install-jhecks\Trac-1.0-py2.7-win32.egg.tmp\trac\web\api.py", line 307, in __getattr__
    raise AttributeError(name)
AttributeError: hdf

Attachments (0)

Change History (1)

comment:1 Changed 17 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7066. You won't be able to use this plugin in Trac 1.0 because the plugin still uses t:ClearSilver for its templates. The templates need to be converted to Genshi.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from sambloomquist. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.