Modify

#10961 closed defect (duplicate)

Selecting to diff any part of a ticket with changes causes a Trac internal error

Reported by: anonymous Owned by: rjollos
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords: diff link needinfo
Cc: jpsecher Trac Release: 0.12

Description

Selecting any (diff) link on a ticket causes:

Trac detected an internal error:
  KeyError: 'fields'

Python Traceback

Most recent call last:
File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 511, in _dispatch_request
File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 248, in dispatch
File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 357, in _post_process_request
File "/usr/lib/pymodules/python2.6/mastertickets/web_ui.py", line 64, in post_process_request

System Information

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.172 Safari/537.22

Trac	0.12.2
Genshi	0.6
mod_python	3.3.1
Pygments	1.3.1
pysqlite	2.6.0
Python	2.6.6 (r266:84292, Dec 27 2010, 00:18:12) [GCC 4.4.5]
pytz	2010b
setuptools	0.6
SQLite	3.7.3
Subversion	1.6.12 (r955767)
jQuery	1.4.2

Enabled Plugins

TracMasterTickets	3.0.2	/usr/lib/pymodules/python2.6

Attachments (0)

Change History (19)

comment:1 Changed 20 months ago by rjollos

  • Keywords diff link added

Thank you for the report. Could you please upgrade to 3.0.4 and try to reproduce?

comment:2 Changed 20 months ago by rjollos

  • Keywords needinfo added

I can't reproduce in Trac 0.12 or 1.0.1. Please try the latest version of MasterTicketsPlugin, and if you can reproduce I'll need some more information to be able to reproduce locally.

comment:3 Changed 19 months ago by anonymous

Any chance of a link to a 3.0.4 unofficial .deb so I can keep my install debian compliant while seeing if the problem is resolve?

comment:4 Changed 19 months ago by rjollos

I've never created a deb package, but I'd be interested to try if you have any pointers. Either way, we should wait until 3.0.5, which I'll have out by the end of the week.

comment:5 follow-up: Changed 19 months ago by anonymous

  1. Pulled down the current git version and installed it on a non-production Trac 0.12 install. Git version did not have the issue that 3.0.2 had via the unofficial .deb on the MasterTicketsPlugin page. However, in Trac->Admin->Plugins plugin info still displayed as "TracMasterTickets 3.0.2".

3.0.2 was installed via the unofficial .deb before the git version was.

comment:6 follow-up: Changed 19 months ago by anonymous

My experience with building .debs has been from recompiling debian source packages or hackily doing one or two file updates/customization in a .deb.

Know they are an archive file which can be manipulated by the ar utility from debian binutils package. Once extracted, the data.tar.gz is the directory tree of what is to be installed via the package. The control.tar.gz contains the postinstall and uninstall scripts for the package.

comment:7 in reply to: ↑ 5 Changed 19 months ago by rjollos

Replying to anonymous:

... However, in Trac->Admin->Plugins plugin info still displayed as "TracMasterTickets 3.0.2".

I have no idea why that would be. I'm glad to know your issue is resolved though, and I will keep in on my priority list to figure out how to build and distribute a deb package.

comment:8 Changed 19 months ago by anonymous

fyi-

The version still showing as 3.0.2 apparently was a caching issue. Brought the VM up with the non-production trac instance today and TracMasterTickets now displays as 3.0.4.

comment:9 Changed 19 months ago by rjollos

As far as you know, did it just require a restart of Trac to update the cached version info?

comment:10 Changed 19 months ago by anonymous

I cannot be positive since there was a couple days between. However, my web browsers are usually up for weeks at a time. So the shutdown and restart of the VM with the Trac instance is the likely trigger for the TracMasterTickets version updating and displaying correctly.

comment:11 in reply to: ↑ 6 Changed 19 months ago by rjollos

  • Cc jpsecher added

Replying to anonymous:

My experience with building .debs has been from recompiling debian source packages or hackily doing one or two file updates/customization in a .deb.

The deb file on the MasterTicketsPlugin page is currently hosted on someone's DropBox account. The wiki page edit was made by jpsecher, so I'll assume that person is hosting the deb and ask if they will provide a new unoffical deb at that location.

Is there a package index where I could provide a deb package, similar to Python's PyPI?

comment:12 Changed 19 months ago by jpsecher

OK, so you want me to make a Debian package of version 3.0.4, right?

comment:13 follow-up: Changed 19 months ago by rjollos

I'll have 3.0.5 ready soon. Maybe we should just wait and I'll ping you when 3.0.5 is ready?

comment:14 in reply to: ↑ 13 Changed 19 months ago by jpsecher

Replying to rjollos:

I'll have 3.0.5 ready soon. Maybe we should just wait and I'll ping you when 3.0.5 is ready?

OK, I am tied up the next couple of days anyway.

comment:15 Changed 19 months ago by rjollos

Thanks, I will ping you again when 3.0.5 is ready.

comment:16 Changed 19 months ago by rjollos

(In [12943]) Refs #10961: Refactored [12910] to remove use of deprecated has_key method.

comment:17 Changed 19 months ago by rjollos

(In [12944]) Refs #10961: Fixed typo in [12943].

comment:18 Changed 19 months ago by rjollos

This was fixed in [12910]. The version was bumped to 3.0.1 in [12911], so this should have been resolved by 3.0.2.

jpsecher: I'll CC you in another ticket when 3.0.5 is ready.

comment:19 Changed 19 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3920.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.