Modify

Opened 20 months ago

Closed 20 months ago

Last modified 16 months ago

#11047 closed defect (fixed)

Report view is not filtering reports

Reported by: Laurentlafon Owned by: rjollos
Priority: normal Component: PrivateReportsPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description (last modified by rjollos)

Hello,

I'm trying to install the PrivateReportsPlugin but seems like the filter is not working.

  1. I've created a new permission for one report and added it to a user group.
  2. The user group also has the REPORT_VIEW right to access the "view ticket" page.

When accessing the "view ticket" page with another user without the report permission, the report is still visible. But if I click on the report, I do have the "you don't have permission to access this report" error.

So it seems like the plugin is working in some way.

Thanks for your help,

Laurent Lafon

My current setup:

Trac	    1.0.1
Babel	    0.9.6
Genshi	    0.6 (with speedups)
pysqlite    2.6.0
Python	    2.7.1+ (r271:86832, Sep 27 2012, 21:12:17) [GCC 4.5.2]
RPC	    1.1.2-r12546
setuptools  0.6
SQLite	    3.7.4
jQuery	    1.7.2

Attachments (2)

t11047-r13030-1.patch (2.6 KB) - added by rjollos 20 months ago.
ReportListPage.png (11.9 KB) - added by rjollos 20 months ago.

Download all attachments as: .zip

Change History (31)

comment:1 Changed 20 months ago by rjollos

  • Description modified (diff)

comment:2 Changed 20 months ago by rjollos

l.lafon at cacom.fr: May I suggest that you register for an account here? That will avoid having to put your email address in the Reporter field, and if you login before submitting a ticket, you will receive notifications on ticket updates. I can assure you that we keep you email address private when you register :)

comment:3 Changed 20 months ago by rjollos

  • Description modified (diff)

comment:4 follow-up: Changed 20 months ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

I did a quick review of the source code and tested with Trac 1.0.2dev, generating #11048 and #11049. In #11049, I suggested that the functionality of this plugin could even be implemented entirely using t:TracFineGrainedPermissions.

There is no code in IRequestFilter to remove reports from the list on the /report page, so the behavior you describe seems to be the intended behavior.

I'll do some more investigation about the possibility of implementing the feature using t:TracFineGrainedPermissions and report back here. Let me know if you are interested in possibly going that route, and if so I'll make it a priority to do some testing soon. If things are working correctly in the Trac core, the link to a report that the user doesn't have permission to view should either appear as "greyed out", or be filtered from the list. I suspect it's the former, and that's probably okay - the report title would be exposed to the user that doesn't have the permission, but they wouldn't be able to follow the link.

Changed 20 months ago by rjollos

comment:5 in reply to: ↑ 4 Changed 20 months ago by rjollos

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to rjollos:

There is no code in IRequestFilter to remove reports from the list on the /report page, so the behavior you describe seems to be the intended behavior.

I was wrong about this. The code is in ITemplateStreamFilter.filter_stream, however it appears to not be working correctly, as you suggest.

t11047-r13030-1.patch is a patch to fix the issue (there is a bit of white-space change noise in the patch due to auto-formatting by my IDE). It is pretty ugly, and relies on the "report rows" having View report as the value of the title attribute for the a elements. I'm sure there is a better way to do this, and this patch is just a first cut. I'll take another look tomorrow.

The problem here is basically the same issue as with the PrivateCommentPlugin in #11010. The implementation isn't robust to changes in the Trac templates, which inevitably occur with every release, or when a custom theme is used. The suggestions in #11049 may lead to a more robust implementation.

comment:6 Changed 20 months ago by Laurentlafon

rjollos: I've created an account.

I've already setup TracFineGrainedPermissions to filter wiki pages, so I'm fine using it to filter reports as well.

Thanks,

Laurent

comment:7 Changed 20 months ago by rjollos

  • Reporter changed from l.lafon@… to Laurentlafon

t:TracFineGrainedPermissions seem to work okay for the Reports realm.

  • Grant REPORT_VIEW for everyone that you want to see the Reports list page. A user must have the coarse-grained REPORT_VIEW permission to navigate to the /report page (see here).
  • Grant REPORT_VIEW for the specific reports that you want users to see, and then revoke the REPORT_VIEW permission for all other resources.
    [report:1]
    anonymous = REPORT_VIEW
    
    [report:4]
    anonymous = REPORT_VIEW
    
    [report:*]
    * =
    
  • An alternate approach would be to hide specific reports, and grant REPORT_VIEW for all other resources. Whereas the prior example granted anonymous permission to view only reports 1 and 4, the following allows anonymous to view all reports except 1 and 4.
    [report:1]
    anonymous =            
    
    [report:4]
    anonymous = 
    
  • Unfortunately, these fine-grained permissions configurations still result in a normal-looking report link on the Report list page, even when the user doesn't have permission to view the report; which is basically the problem that you opened this ticket to report. See t:#11176 for details, and a forthcoming fix. Please feel free to comment on that ticket if you have any thoughts on the proposed behavior.

Best case is that we'll have a fix for t:#11176 in Trac 1.0.2, so I'll go ahead and put some fixes in place for this plugin so that it is usable with Trac 1.0 now.

comment:8 Changed 20 months ago by rjollos

  • Owner changed from mhenke to rjollos
  • Status changed from reopened to new

comment:9 Changed 20 months ago by rjollos

  • Status changed from new to assigned

comment:10 Changed 20 months ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [13041]) Fixes #11047: Report list was not being correctly filtered in Trac 1.0.

comment:11 Changed 20 months ago by rjollos

Laurentlafon: I've completed all of the work I had in mind for this plugin. Testing has been done with Trac 0.12-stable and Trac 1.0-stable.

Let me know if you encounter any other issues, and I'd even be interested to know if you install the latest version and everything goes smoothly. If it seems to be working well, I'll remove the dev from the version number and create a tag. Please track t:#11176 and #9947 if you are interested in the t:TracFineGrainedPermissions implementation.

comment:12 Changed 20 months ago by Laurentlafon

Thanks for your help,

I've installed the patch, and now, nothing shows on the Report list page (no link report at all). I've added permission created with the Private Reports admin page to my admin user but nothing shows either.

I've got a similar problem with the ComponentPermissionsPlugin (i.e. component permissions are available on the Permissions page, added to users, but to no avail).

I'm starting to think my problem is config specific. I'll try to dig a bit more.

Thanks for your help anyway,

Laurent

comment:13 Changed 20 months ago by rjollos

(In [13136]) Refs #11047:

  • Refactored _get_report_permissions method.
  • Added logging when reports are removed from the Report List page.

comment:14 Changed 20 months ago by rjollos

Replying to Laurentlafon:

I've installed the patch, and now, nothing shows on the Report list page (no link report at all).

Do you mean that there are no reports listed on the Report list page, or that there isn't even an View Tickets link on the mainnav?

I added some logging to try to help debug the situation. After updating to the latest version, you should see something in the logs when navigating to the report page (see t:TracLogging if you aren't familiar). Here is an example of what I see after defining a REPORT_2_VIEW permission but not granting it to user1 whom I'm logged in as:

12:49:12 AM Trac[privatereports] DEBUG: Removing report 2 from list becauseuser1 doesn't have required permission.

Do you see the appropriate TracError when navigating directly to the report?

I'm happy to try to help if I can, so feel free to follow-up here as you find more info. If I broke the plugin in any way, I want to make sure to fix it :)

Changed 20 months ago by rjollos

comment:15 Changed 20 months ago by Laurentlafon

I've upgraded to the latest version of the plugin (PrivateReports 0.4dev-r13137), logging is set to "DEBUG".

  • I can access reports via direct URL
  • I can access the report list page, but no reports are listed there.
  • The log is only showing [authz_policy] and [perm] checks.
  • I've noticed a weird behavior. My user has access to report 9 : when accessing the direct URL (/report/9), it is redirected to the main report page (/report).

comment:16 Changed 20 months ago by rjollos

What is in your authz_policy? It might be worthwhile to temporarily disable tracopt.perm.authz_policy.* and see what the behavior is.

comment:17 Changed 20 months ago by rjollos

Could you also post the full list of plugin that you have installed?

comment:18 Changed 20 months ago by rjollos

(In [13151]) Refs #11047:

  • Reworded log message from [13136].
  • Added a debug-level log message when user is blocked from viewing a report.

comment:19 Changed 20 months ago by rjollos

I changed the log message that was added in [13136]:

08:21:57 PM Trac[privatereports] DEBUG: Removing report 1 from list because anonymous doesn't have permission to view

In [13151], I also added a debug-level log message when a user is blocked from viewing a report (for the case below, anonymous was prevented from viewing report 1 when entering /report/1 for the URL):

08:18:32 PM Trac[privatereports] DEBUG: User anonymous doesn't have permission to view report 1

comment:20 Changed 19 months ago by Laurentlafon

I have:

  • installed the latest version of the plugin
  • removed Authz_policy from permission_policies
  • disabled tracopt.perm.authz_policy.*

Then when trying to access the Report list page:

  • I can access the page but can only see "Available reports" but no report
  • With log level set to DEBUG, I cannot see any Trac[privatereports] DEBUG info
  • Filtering when accessing the report via the direct URL works OK

And here is the list of the plugin:

ComponentPermissionsPlugin	0.1.2	/usr/local/lib/python2.7/dist-packages/ComponentPermissionsPlugin-0.1.2-py2.7.egg
ExcelDownloadPlugin	0.12.0.3	/usr/local/lib/python2.7/dist-packages/ExcelDownloadPlugin-0.12.0.3-py2.7.egg
GroupBasedRedirection	0.2	/usr/local/lib/python2.7/dist-packages/GroupBasedRedirection-0.2-py2.7.egg
hideable-query	0.1	/usr/local/lib/python2.7/dist-packages/hideable_query-0.1-py2.7.egg
PageAuthzPolicyEditor	0.12dev-r12560	/usr/local/lib/python2.7/dist-packages/PageAuthzPolicyEditor-0.12dev_r12560-py2.7.egg
PrivateComments	0.4dev-r13050	/usr/local/lib/python2.7/dist-packages/PrivateComments-0.4dev_r13050-py2.7.egg
PrivateReports	0.4dev-r13151	/usr/local/lib/python2.7/dist-packages/PrivateReports-0.4dev_r13151-py2.7.egg
TicketBox	Rev	/var/trac/plugins/TicketBox.pyc
TicketLastCommentJumpPlugin	0.1	/usr/local/lib/python2.7/dist-packages/TicketLastCommentJumpPlugin-0.1-py2.7.egg
TracAccountManager	0.4.3	/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
TracCustomFieldAdmin	0.2.8-r12166	/usr/local/lib/python2.7/dist-packages/TracCustomFieldAdmin-0.2.8_r12166-py2.7.egg
TracHtGroupEditorPlugin	2.0	/usr/local/lib/python2.7/dist-packages/TracHtGroupEditorPlugin-2.0-py2.7.egg
TracHTTPAuth	1.1	/usr/local/lib/python2.7/dist-packages/TracHTTPAuth-1.1-py2.7.egg
TracIniAdminPanel	0.81beta-r533	/usr/local/lib/python2.7/dist-packages/TracIniAdminPanel-0.81beta_r533-py2.7.egg
TracPermRedirect	2.0	/usr/local/lib/python2.7/dist-packages/TracPermRedirect-2.0-py2.7.egg
TracWorkflowAdmin	0.12.0.2	/usr/local/lib/python2.7/dist-packages/TracWorkflowAdmin-0.12.0.2-py2.7.egg
TracWysiwyg	0.12.0.4-r12680	/usr/local/lib/python2.7/dist-packages/TracWysiwyg-0.12.0.4_r12680-py2.7.egg
TracXMLRPC	1.1.2-r12546	/usr/local/lib/python2.7/dist-packages/TracXMLRPC-1.1.2_r12546-py2.7.egg

comment:21 Changed 19 months ago by rjollos

I created a fresh install with 1.0.1 and added permissions to reports 1, 2 and 3. Now, anonymous has permission to view report 2, but not 1 and 3.

Here is what I see in the console with the log level set to DEBUG and refreshing the /report page:

10:26:23 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/report'">
10:26:23 PM Trac[chrome] DEBUG: Prepare chrome data for request
10:26:23 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing TRAC_ADMIN on None
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing PERMISSION_GRANT on None
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing PERMISSION_REVOKE on None
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing TICKET_ADMIN on None
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing VERSIONCONTROL_ADMIN on None
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing TICKET_CREATE on None
10:26:23 PM Trac[api] INFO: Synchronized '(default)' repository in 0.00 seconds
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_MODIFY on <Resource u'report:1'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_DELETE on <Resource u'report:1'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_MODIFY on <Resource u'report:2'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_DELETE on <Resource u'report:2'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_MODIFY on <Resource u'report:3'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_DELETE on <Resource u'report:3'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_MODIFY on <Resource u'report:4'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_DELETE on <Resource u'report:4'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_MODIFY on <Resource u'report:5'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_DELETE on <Resource u'report:5'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_MODIFY on <Resource u'report:6'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_DELETE on <Resource u'report:6'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_MODIFY on <Resource u'report:7'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_DELETE on <Resource u'report:7'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_MODIFY on <Resource u'report:8'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_DELETE on <Resource u'report:8'>
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing EMAIL_VIEW on None
10:26:23 PM Trac[privatereports] DEBUG: Removing report 1 from list because anonymous doesn't have permission to view
10:26:23 PM Trac[privatereports] DEBUG: Removing report 3 from list because anonymous doesn't have permission to view
10:26:23 PM Trac[perm] DEBUG: No policy allowed anonymous performing REPORT_CREATE on None
127.0.0.1 - - [21/May/2013 22:26:23] "GET /tracdev/report HTTP/1.1" 200 -
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/css/trac.css'">
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/css/report.css'">
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/js/jquery.js'">
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/js/search.js'">
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/js/babel.js'">
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/js/trac.js'">
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/css/report.css HTTP/1.1" 304 -
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/js/trac.js HTTP/1.1" 304 -
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/css/trac.css HTTP/1.1" 304 -
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/js/search.js HTTP/1.1" 304 -
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/js/jquery.js HTTP/1.1" 304 -
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/js/babel.js HTTP/1.1" 304 -
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/js/folding.js'">
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/js/folding.js HTTP/1.1" 304 -
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/css/code.css'">
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/css/code.css HTTP/1.1" 304 -
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/site/your_project_logo.png'">
10:26:24 PM Trac[chrome] WARNING: File your_project_logo.png not found in any of ['/home/user/Workspace/th11047/tracdev/htdocs']
10:26:24 PM Trac[main] WARNING: [127.0.0.1] HTTPNotFound: 404 Not Found (File your_project_logo.png not found)
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
10:26:24 PM Trac[chrome] DEBUG: Prepare chrome data for request
10:26:24 PM Trac[perm] DEBUG: No policy allowed anonymous performing TRAC_ADMIN on None
10:26:24 PM Trac[perm] DEBUG: No policy allowed anonymous performing PERMISSION_GRANT on None
10:26:24 PM Trac[perm] DEBUG: No policy allowed anonymous performing PERMISSION_REVOKE on None
10:26:24 PM Trac[perm] DEBUG: No policy allowed anonymous performing TICKET_ADMIN on None
10:26:24 PM Trac[perm] DEBUG: No policy allowed anonymous performing VERSIONCONTROL_ADMIN on None
10:26:24 PM Trac[perm] DEBUG: No policy allowed anonymous performing TICKET_CREATE on None
10:26:24 PM Trac[perm] DEBUG: No policy allowed anonymous performing EMAIL_VIEW on None
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/trac_logo_mini.png'">
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
10:26:24 PM Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/chrome/common/asc.png'">
10:26:24 PM Trac[session] DEBUG: Retrieving session for ID '38e03ab3aa3838572b84eb69'
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/asc.png HTTP/1.1" 304 -
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/common/trac_logo_mini.png HTTP/1.1" 304 -
127.0.0.1 - - [21/May/2013 22:26:24] "GET /tracdev/chrome/site/your_project_logo.png HTTP/1.1" 404 -

Please post the same for you Trac instance so that we can compare the logs and see if anything sticks out.

Another technique that is often effective is to disable all the plugins except PrivateReportsPlugin and if things work well in that case, then enable the plugins one by one until it stops working.

comment:22 Changed 19 months ago by rjollos

(In [13240]) Refs #11047: FIX: The 'Return to Last Query' and 'Custom Query' links were being filtered from the report_list page (these links only exist in Trac 1.0 and later).

comment:23 Changed 19 months ago by rjollos

Laurentlafon: Could you try again with r13240?

comment:24 follow-up: Changed 19 months ago by anonymous

rjollos: sorry for the delay in replaying (I've been quite busy).

Same behavior as before (no filtering on the report listing page, but URL are filtered accordingly), except than now users can see the list of all the reports on the report listing page, including the ones they cannot access. Reports are not grayed out even if user don't have access.

When I have some time I'll do a run-down deactivating all plugins and reinstating them one by one and try figure where it is going wrong.

In the meantime, I've found a suitable workaround. I've embedded the reports into wiki pages (filtered with finegrained permissions policy) and removed the Report View to all users other than admin. I'm using the private reports plugin to filter direct URL access.

Thanks for your help,

Laurent

Last edited 19 months ago by rjollos (previous) (diff)

comment:25 in reply to: ↑ 24 Changed 19 months ago by rjollos

Replying to anonymous:

rjollos: sorry for the delay in replaying (I've been quite busy).

Same behavior as before (no filtering on the report listing page, but URL are filtered accordingly), except than now users can see the list of all the reports on the report listing page, including the ones they cannot access. Reports are not grayed out even if user don't have access.

The only thing I can think, is that the HTML on your report page is somehow different. Perhaps you have some site customizations, a theme, or a plugin is modifying the page?

When I have some time I'll do a run-down deactivating all plugins and reinstating them one by one and try figure where it is going wrong.

That's a great next debug step.

comment:26 follow-up: Changed 19 months ago by Laurentlafon

Hello,

I've done some more testing. Getting rid of the theme didn't change anything. deactivating every plugin (but the accountmanager) didn't change anything either. I can however see the messages in the debug when trying to access report/*

When trying to access a specific URL (report 6 for example) :

2013-06-17 18:07:35,777 Trac[env] INFO: -------------------------------- environment startup [Trac 1.0.1] --------------------------------
2013-06-17 18:07:35,792 Trac[loader] DEBUG: Loading GroupBasedRedirection from /usr/local/lib/python2.7/dist-packages/GroupBasedRedirection-0.2-py2.7.egg
2013-06-17 18:07:35,793 Trac[loader] DEBUG: Loading HtGroupEditor from /usr/local/lib/python2.7/dist-packages/TracHtGroupEditorPlugin-2.0-py2.7.egg
2013-06-17 18:07:35,801 Trac[loader] DEBUG: Loading PrivateComments from /usr/local/lib/python2.7/dist-packages/PrivateComments-0.4dev_r13050-py2.7.egg
2013-06-17 18:07:35,808 Trac[loader] DEBUG: Loading PrivateReports from /usr/local/lib/python2.7/dist-packages/PrivateReports-0.4dev_r13240-py2.7.egg
2013-06-17 18:07:35,810 Trac[loader] DEBUG: Loading TicketLastCommentJump from /usr/local/lib/python2.7/dist-packages/TicketLastCommentJumpPlugin-0.1-py2.7.egg
2013-06-17 18:07:35,810 Trac[loader] DEBUG: Loading TracXMLRPC from /usr/local/lib/python2.7/dist-packages/TracXMLRPC-1.1.2_r12546-py2.7.egg
2013-06-17 18:07:35,819 Trac[loader] DEBUG: Loading acct_mgr.admin from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,824 Trac[loader] DEBUG: Loading acct_mgr.api from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,824 Trac[loader] DEBUG: Loading acct_mgr.db from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,824 Trac[loader] DEBUG: Loading acct_mgr.htfile from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,824 Trac[loader] DEBUG: Loading acct_mgr.http from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,825 Trac[loader] DEBUG: Loading acct_mgr.macros from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,825 Trac[loader] DEBUG: Loading acct_mgr.notification from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,825 Trac[loader] DEBUG: Loading acct_mgr.pwhash from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,826 Trac[loader] DEBUG: Loading acct_mgr.svnserve from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,826 Trac[loader] DEBUG: Loading acct_mgr.web_ui from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:07:35,826 Trac[loader] DEBUG: Loading componentpermissions from /usr/local/lib/python2.7/dist-packages/ComponentPermissionsPlugin-0.1.5-py2.7.egg
2013-06-17 18:07:35,827 Trac[loader] DEBUG: Loading customfieldadmin.admin from /usr/local/lib/python2.7/dist-packages/TracCustomFieldAdmin-0.2.8_r12166-py2.7.egg
2013-06-17 18:07:35,828 Trac[loader] DEBUG: Loading customfieldadmin.api from /usr/local/lib/python2.7/dist-packages/TracCustomFieldAdmin-0.2.8_r12166-py2.7.egg
2013-06-17 18:07:35,828 Trac[loader] DEBUG: Loading hideable_query from /usr/local/lib/python2.7/dist-packages/hideable_query-0.1-py2.7.egg
2013-06-17 18:07:35,829 Trac[loader] DEBUG: Loading httpauth.filter from /usr/local/lib/python2.7/dist-packages/TracHTTPAuth-1.1-py2.7.egg
2013-06-17 18:07:35,829 Trac[loader] DEBUG: Loading inieditorpanel.default_manager from /usr/local/lib/python2.7/dist-packages/TracIniAdminPanel-0.81beta_r533-py2.7.egg
2013-06-17 18:07:35,830 Trac[loader] DEBUG: Loading inieditorpanel.web_ui from /usr/local/lib/python2.7/dist-packages/TracIniAdminPanel-0.81beta_r533-py2.7.egg
2013-06-17 18:07:35,830 Trac[loader] DEBUG: Loading page_authz_policy_editor.admin from /usr/local/lib/python2.7/dist-packages/PageAuthzPolicyEditor-0.12dev_r12560-py2.7.egg
2013-06-17 18:07:35,831 Trac[loader] DEBUG: Loading permredirect.filter from /usr/local/lib/python2.7/dist-packages/TracPermRedirect-2.0-py2.7.egg
2013-06-17 18:07:35,832 Trac[loader] DEBUG: Loading trac.about from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,832 Trac[loader] DEBUG: Loading trac.admin.console from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,834 Trac[loader] DEBUG: Loading trac.admin.web_ui from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,834 Trac[loader] DEBUG: Loading trac.attachment from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,834 Trac[loader] DEBUG: Loading trac.db.mysql from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,837 Trac[loader] DEBUG: Loading trac.db.postgres from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,838 Trac[loader] DEBUG: Loading trac.db.sqlite from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,839 Trac[loader] DEBUG: Loading trac.mimeview.patch from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,839 Trac[loader] DEBUG: Loading trac.mimeview.pygments from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,847 Trac[loader] DEBUG: Skipping "trac.mimeview.pygments = trac.mimeview.pygments [pygments]": ("DistributionNotFound: Pygments>=0.6" not found)
2013-06-17 18:07:35,848 Trac[loader] DEBUG: Loading trac.mimeview.rst from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,855 Trac[loader] DEBUG: Skipping "trac.mimeview.rst = trac.mimeview.rst [rest]": ("DistributionNotFound: docutils>=0.3" not found)
2013-06-17 18:07:35,855 Trac[loader] DEBUG: Loading trac.mimeview.txtl from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,862 Trac[loader] DEBUG: Skipping "trac.mimeview.txtl = trac.mimeview.txtl [textile]": ("DistributionNotFound: textile>=2.0" not found)
2013-06-17 18:07:35,862 Trac[loader] DEBUG: Loading trac.prefs from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,862 Trac[loader] DEBUG: Loading trac.search from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,862 Trac[loader] DEBUG: Loading trac.ticket.admin from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,863 Trac[loader] DEBUG: Loading trac.ticket.batch from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,863 Trac[loader] DEBUG: Loading trac.ticket.query from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,864 Trac[loader] DEBUG: Loading trac.ticket.report from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,864 Trac[loader] DEBUG: Loading trac.ticket.roadmap from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,864 Trac[loader] DEBUG: Loading trac.ticket.web_ui from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,865 Trac[loader] DEBUG: Loading trac.timeline from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,865 Trac[loader] DEBUG: Loading trac.versioncontrol.admin from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,866 Trac[loader] DEBUG: Loading trac.versioncontrol.svn_authz from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,866 Trac[loader] DEBUG: Loading trac.versioncontrol.web_ui from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,870 Trac[loader] DEBUG: Loading trac.web.auth from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,870 Trac[loader] DEBUG: Loading trac.web.session from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,870 Trac[loader] DEBUG: Loading trac.wiki.admin from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,870 Trac[loader] DEBUG: Loading trac.wiki.interwiki from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,871 Trac[loader] DEBUG: Loading trac.wiki.macros from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,871 Trac[loader] DEBUG: Loading trac.wiki.web_api from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,871 Trac[loader] DEBUG: Loading trac.wiki.web_ui from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,872 Trac[loader] DEBUG: Loading tracexceldownload.ticket from /usr/local/lib/python2.7/dist-packages/ExcelDownloadPlugin-0.12.0.3-py2.7.egg
2013-06-17 18:07:35,883 Trac[loader] DEBUG: Loading tracexceldownload.translation from /usr/local/lib/python2.7/dist-packages/ExcelDownloadPlugin-0.12.0.3-py2.7.egg
2013-06-17 18:07:35,883 Trac[loader] DEBUG: Loading tracopt.mimeview.enscript from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,884 Trac[loader] DEBUG: Loading tracopt.mimeview.php from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,884 Trac[loader] DEBUG: Loading tracopt.mimeview.silvercity from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,892 Trac[loader] DEBUG: Skipping "tracopt.mimeview.silvercity = tracopt.mimeview.silvercity [silvercity]": ("DistributionNotFound: SilverCity>=0.9.4" not found)
2013-06-17 18:07:35,892 Trac[loader] DEBUG: Loading tracopt.perm.authz_policy from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,893 Trac[loader] DEBUG: Loading tracopt.perm.config_perm_provider from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,893 Trac[loader] DEBUG: Loading tracopt.ticket.clone from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,893 Trac[loader] DEBUG: Loading tracopt.ticket.commit_updater from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,894 Trac[loader] DEBUG: Loading tracopt.ticket.deleter from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,895 Trac[loader] DEBUG: Loading tracopt.versioncontrol.git.git_fs from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,897 Trac[loader] DEBUG: Loading tracopt.versioncontrol.svn.svn_fs from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,898 Trac[loader] DEBUG: Loading tracopt.versioncontrol.svn.svn_prop from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:07:35,898 Trac[loader] DEBUG: Loading tracworkflowadmin.web_ui from /usr/local/lib/python2.7/dist-packages/TracWorkflowAdmin-0.12.0.2-py2.7.egg
2013-06-17 18:07:35,900 Trac[loader] DEBUG: Loading tracwysiwyg from /usr/local/lib/python2.7/dist-packages/TracWysiwyg-0.12.0.4_r12680-py2.7.egg
2013-06-17 18:07:35,900 Trac[loader] DEBUG: Loading file plugin TicketBox from /var/trac/plugins/TicketBox.py
2013-06-17 18:07:35,902 Trac[default_workflow] DEBUG: Workflow actions at initialization: {u'infoneeded': {'operations': [], u'name': u'En attente retour client', u'default': 995, 'newstate': u'Waitingforinfo', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened'], u'permissions': [u'TICKET_MODIFY']}, u'resolve': {u'operations': [u'set_resolution'], u'name': u'R\xe9solu', u'default': 998, 'newstate': u'closed', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened', u'Waitingforinfo'], u'permissions': [u'TICKET_APPEND', u'TICKET_MODIFY']}, u'accept': {u'operations': [u'set_owner_to_self'], u'name': u'Accept\xe9', u'default': 997, 'newstate': u'accepted', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened', u'Waitingforinfo'], u'permissions': [u'TICKET_MODIFY']}, u'leave': {u'operations': [u'leave_status'], u'name': u'laisser', u'default': 1000, 'newstate': u'*', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened', u'closed', u'Waitingforinfo'], u'permissions': [u'TICKET_APPEND', u'TICKET_MODIFY']}, u'reopen': {u'operations': [u'del_resolution'], u'name': u'R\xe9ouvrir', u'default': 996, 'newstate': u'reopened', 'oldstates': [u'closed'], u'permissions': [u'TICKET_CREATE']}, u'reassign': {u'operations': [u'set_owner'], u'name': u'R\xe9assigner', u'default': 999, 'newstate': u'assigned', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened', u'Waitingforinfo'], u'permissions': [u'TICKET_MODIFY']}, '_reset': {'operations': ['reset_workflow'], 'name': 'reset', 'default': 0, 'newstate': 'new', 'oldstates': [], 'permissions': []}}

2013-06-17 18:07:35,905 Trac[env] WARNING: base_url option not set in configuration, generated links may be incorrect
2013-06-17 18:07:35,905 Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/report/6'">
2013-06-17 18:07:35,908 Trac[session] DEBUG: Retrieving session for ID u'leclerc'
2013-06-17 18:07:35,908 Trac[main] DEBUG: Negotiated locale: None -> fr
2013-06-17 18:07:35,914 Trac[api] WARNING: Unable to find repository '(default)' for synchronization
2013-06-17 18:07:35,914 Trac[api] DEBUG: action controllers for ticket workflow: ['ConfigurableTicketWorkflow']
2013-06-17 18:07:35,916 Trac[privatereports] DEBUG: User leclerc doesn't have permission to view report 6 
2013-06-17 18:07:35,916 Trac[main] WARNING: [127.0.0.1] HTTPInternalError: 500 No Permission (You don't have permission to access this report)
2013-06-17 18:07:35,930 Trac[chrome] DEBUG: Prepare chrome data for request
2013-06-17 18:07:35,933 Trac[perm] DEBUG: No policy allowed leclerc performing TICKET_CREATE on None
2013-06-17 18:07:35,933 Trac[perm] DEBUG: No policy allowed leclerc performing TICKET_VIEW on None
2013-06-17 18:07:35,934 Trac[perm] DEBUG: No policy allowed leclerc performing SEARCH_VIEW on None
2013-06-17 18:07:35,934 Trac[perm] DEBUG: No policy allowed leclerc performing TRAC_ADMIN on None
2013-06-17 18:07:35,934 Trac[perm] DEBUG: No policy allowed leclerc performing ACCTMGR_CONFIG_ADMIN on None
2013-06-17 18:07:35,935 Trac[perm] DEBUG: No policy allowed leclerc performing ACCTMGR_USER_ADMIN on None
2013-06-17 18:07:35,935 Trac[perm] DEBUG: No policy allowed leclerc performing TICKET_ADMIN on None
2013-06-17 18:07:35,935 Trac[perm] DEBUG: No policy allowed leclerc performing PERMISSION_GRANT on None
2013-06-17 18:07:35,935 Trac[perm] DEBUG: No policy allowed leclerc performing PERMISSION_REVOKE on None
2013-06-17 18:07:35,936 Trac[perm] DEBUG: No policy allowed leclerc performing MILESTONE_VIEW on None
2013-06-17 18:07:35,936 Trac[perm] DEBUG: No policy allowed leclerc performing VERSIONCONTROL_ADMIN on None
2013-06-17 18:07:35,936 Trac[perm] DEBUG: No policy allowed leclerc performing ROADMAP_VIEW on None
2013-06-17 18:07:35,937 Trac[perm] DEBUG: No policy allowed leclerc performing TIMELINE_VIEW on None
2013-06-17 18:07:35,937 Trac[perm] DEBUG: No policy allowed leclerc performing BROWSER_VIEW on None
2013-06-17 18:07:35,938 Trac[perm] DEBUG: No policy allowed leclerc performing EMAIL_VIEW on None


When trying to access /report :

2013-06-17 18:01:12,213 Trac[env] INFO: -------------------------------- environment startup [Trac 1.0.1] --------------------------------
2013-06-17 18:01:12,228 Trac[loader] DEBUG: Loading GroupBasedRedirection from /usr/local/lib/python2.7/dist-packages/GroupBasedRedirection-0.2-py2.7.egg
2013-06-17 18:01:12,229 Trac[loader] DEBUG: Loading HtGroupEditor from /usr/local/lib/python2.7/dist-packages/TracHtGroupEditorPlugin-2.0-py2.7.egg
2013-06-17 18:01:12,237 Trac[loader] DEBUG: Loading PrivateComments from /usr/local/lib/python2.7/dist-packages/PrivateComments-0.4dev_r13050-py2.7.egg
2013-06-17 18:01:12,244 Trac[loader] DEBUG: Loading PrivateReports from /usr/local/lib/python2.7/dist-packages/PrivateReports-0.4dev_r13240-py2.7.egg
2013-06-17 18:01:12,246 Trac[loader] DEBUG: Loading TicketLastCommentJump from /usr/local/lib/python2.7/dist-packages/TicketLastCommentJumpPlugin-0.1-py2.7.egg
2013-06-17 18:01:12,246 Trac[loader] DEBUG: Loading TracXMLRPC from /usr/local/lib/python2.7/dist-packages/TracXMLRPC-1.1.2_r12546-py2.7.egg
2013-06-17 18:01:12,255 Trac[loader] DEBUG: Loading acct_mgr.admin from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,260 Trac[loader] DEBUG: Loading acct_mgr.api from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,260 Trac[loader] DEBUG: Loading acct_mgr.db from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,260 Trac[loader] DEBUG: Loading acct_mgr.htfile from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,261 Trac[loader] DEBUG: Loading acct_mgr.http from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,261 Trac[loader] DEBUG: Loading acct_mgr.macros from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,261 Trac[loader] DEBUG: Loading acct_mgr.notification from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,262 Trac[loader] DEBUG: Loading acct_mgr.pwhash from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,262 Trac[loader] DEBUG: Loading acct_mgr.svnserve from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,262 Trac[loader] DEBUG: Loading acct_mgr.web_ui from /usr/local/lib/python2.7/dist-packages/TracAccountManager-0.4.3-py2.7.egg
2013-06-17 18:01:12,262 Trac[loader] DEBUG: Loading componentpermissions from /usr/local/lib/python2.7/dist-packages/ComponentPermissionsPlugin-0.1.5-py2.7.egg
2013-06-17 18:01:12,263 Trac[loader] DEBUG: Loading customfieldadmin.admin from /usr/local/lib/python2.7/dist-packages/TracCustomFieldAdmin-0.2.8_r12166-py2.7.egg
2013-06-17 18:01:12,264 Trac[loader] DEBUG: Loading customfieldadmin.api from /usr/local/lib/python2.7/dist-packages/TracCustomFieldAdmin-0.2.8_r12166-py2.7.egg
2013-06-17 18:01:12,264 Trac[loader] DEBUG: Loading hideable_query from /usr/local/lib/python2.7/dist-packages/hideable_query-0.1-py2.7.egg
2013-06-17 18:01:12,265 Trac[loader] DEBUG: Loading httpauth.filter from /usr/local/lib/python2.7/dist-packages/TracHTTPAuth-1.1-py2.7.egg
2013-06-17 18:01:12,266 Trac[loader] DEBUG: Loading inieditorpanel.default_manager from /usr/local/lib/python2.7/dist-packages/TracIniAdminPanel-0.81beta_r533-py2.7.egg
2013-06-17 18:01:12,266 Trac[loader] DEBUG: Loading inieditorpanel.web_ui from /usr/local/lib/python2.7/dist-packages/TracIniAdminPanel-0.81beta_r533-py2.7.egg
2013-06-17 18:01:12,267 Trac[loader] DEBUG: Loading page_authz_policy_editor.admin from /usr/local/lib/python2.7/dist-packages/PageAuthzPolicyEditor-0.12dev_r12560-py2.7.egg
2013-06-17 18:01:12,267 Trac[loader] DEBUG: Loading permredirect.filter from /usr/local/lib/python2.7/dist-packages/TracPermRedirect-2.0-py2.7.egg
2013-06-17 18:01:12,269 Trac[loader] DEBUG: Loading trac.about from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,269 Trac[loader] DEBUG: Loading trac.admin.console from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,270 Trac[loader] DEBUG: Loading trac.admin.web_ui from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,271 Trac[loader] DEBUG: Loading trac.attachment from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,271 Trac[loader] DEBUG: Loading trac.db.mysql from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,274 Trac[loader] DEBUG: Loading trac.db.postgres from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,275 Trac[loader] DEBUG: Loading trac.db.sqlite from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,276 Trac[loader] DEBUG: Loading trac.mimeview.patch from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,276 Trac[loader] DEBUG: Loading trac.mimeview.pygments from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,284 Trac[loader] DEBUG: Skipping "trac.mimeview.pygments = trac.mimeview.pygments [pygments]": ("DistributionNotFound: Pygments>=0.6" not found)
2013-06-17 18:01:12,284 Trac[loader] DEBUG: Loading trac.mimeview.rst from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,292 Trac[loader] DEBUG: Skipping "trac.mimeview.rst = trac.mimeview.rst [rest]": ("DistributionNotFound: docutils>=0.3" not found)
2013-06-17 18:01:12,292 Trac[loader] DEBUG: Loading trac.mimeview.txtl from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,299 Trac[loader] DEBUG: Skipping "trac.mimeview.txtl = trac.mimeview.txtl [textile]": ("DistributionNotFound: textile>=2.0" not found)
2013-06-17 18:01:12,299 Trac[loader] DEBUG: Loading trac.prefs from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,299 Trac[loader] DEBUG: Loading trac.search from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,299 Trac[loader] DEBUG: Loading trac.ticket.admin from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,300 Trac[loader] DEBUG: Loading trac.ticket.batch from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,300 Trac[loader] DEBUG: Loading trac.ticket.query from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,300 Trac[loader] DEBUG: Loading trac.ticket.report from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,301 Trac[loader] DEBUG: Loading trac.ticket.roadmap from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,301 Trac[loader] DEBUG: Loading trac.ticket.web_ui from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,301 Trac[loader] DEBUG: Loading trac.timeline from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,302 Trac[loader] DEBUG: Loading trac.versioncontrol.admin from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,302 Trac[loader] DEBUG: Loading trac.versioncontrol.svn_authz from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,303 Trac[loader] DEBUG: Loading trac.versioncontrol.web_ui from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,307 Trac[loader] DEBUG: Loading trac.web.auth from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,307 Trac[loader] DEBUG: Loading trac.web.session from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,307 Trac[loader] DEBUG: Loading trac.wiki.admin from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,307 Trac[loader] DEBUG: Loading trac.wiki.interwiki from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,308 Trac[loader] DEBUG: Loading trac.wiki.macros from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,308 Trac[loader] DEBUG: Loading trac.wiki.web_api from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,309 Trac[loader] DEBUG: Loading trac.wiki.web_ui from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,309 Trac[loader] DEBUG: Loading tracexceldownload.ticket from /usr/local/lib/python2.7/dist-packages/ExcelDownloadPlugin-0.12.0.3-py2.7.egg
2013-06-17 18:01:12,321 Trac[loader] DEBUG: Loading tracexceldownload.translation from /usr/local/lib/python2.7/dist-packages/ExcelDownloadPlugin-0.12.0.3-py2.7.egg
2013-06-17 18:01:12,321 Trac[loader] DEBUG: Loading tracopt.mimeview.enscript from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,322 Trac[loader] DEBUG: Loading tracopt.mimeview.php from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,322 Trac[loader] DEBUG: Loading tracopt.mimeview.silvercity from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,330 Trac[loader] DEBUG: Skipping "tracopt.mimeview.silvercity = tracopt.mimeview.silvercity [silvercity]": ("DistributionNotFound: SilverCity>=0.9.4" not found)
2013-06-17 18:01:12,330 Trac[loader] DEBUG: Loading tracopt.perm.authz_policy from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,330 Trac[loader] DEBUG: Loading tracopt.perm.config_perm_provider from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,330 Trac[loader] DEBUG: Loading tracopt.ticket.clone from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,331 Trac[loader] DEBUG: Loading tracopt.ticket.commit_updater from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,332 Trac[loader] DEBUG: Loading tracopt.ticket.deleter from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,332 Trac[loader] DEBUG: Loading tracopt.versioncontrol.git.git_fs from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,334 Trac[loader] DEBUG: Loading tracopt.versioncontrol.svn.svn_fs from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,335 Trac[loader] DEBUG: Loading tracopt.versioncontrol.svn.svn_prop from /usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg
2013-06-17 18:01:12,336 Trac[loader] DEBUG: Loading tracworkflowadmin.web_ui from /usr/local/lib/python2.7/dist-packages/TracWorkflowAdmin-0.12.0.2-py2.7.egg
2013-06-17 18:01:12,337 Trac[loader] DEBUG: Loading tracwysiwyg from /usr/local/lib/python2.7/dist-packages/TracWysiwyg-0.12.0.4_r12680-py2.7.egg
2013-06-17 18:01:12,338 Trac[loader] DEBUG: Loading file plugin TicketBox from /var/trac/plugins/TicketBox.py
2013-06-17 18:01:12,340 Trac[default_workflow] DEBUG: Workflow actions at initialization: {u'infoneeded': {'operations': [], u'name': u'En attente retour client', u'default': 995, 'newstate': u'Waitingforinfo', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened'], u'permissions': [u'TICKET_MODIFY']}, u'resolve': {u'operations': [u'set_resolution'], u'name': u'R\xe9solu', u'default': 998, 'newstate': u'closed', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened', u'Waitingforinfo'], u'permissions': [u'TICKET_APPEND', u'TICKET_MODIFY']}, u'accept': {u'operations': [u'set_owner_to_self'], u'name': u'Accept\xe9', u'default': 997, 'newstate': u'accepted', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened', u'Waitingforinfo'], u'permissions': [u'TICKET_MODIFY']}, u'leave': {u'operations': [u'leave_status'], u'name': u'laisser', u'default': 1000, 'newstate': u'*', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened', u'closed', u'Waitingforinfo'], u'permissions': [u'TICKET_APPEND', u'TICKET_MODIFY']}, u'reopen': {u'operations': [u'del_resolution'], u'name': u'R\xe9ouvrir', u'default': 996, 'newstate': u'reopened', 'oldstates': [u'closed'], u'permissions': [u'TICKET_CREATE']}, u'reassign': {u'operations': [u'set_owner'], u'name': u'R\xe9assigner', u'default': 999, 'newstate': u'assigned', 'oldstates': [u'accepted', u'new', u'assigned', u'reopened', u'Waitingforinfo'], u'permissions': [u'TICKET_MODIFY']}, '_reset': {'operations': ['reset_workflow'], 'name': 'reset', 'default': 0, 'newstate': 'new', 'oldstates': [], 'permissions': []}}

2013-06-17 18:01:12,343 Trac[env] WARNING: base_url option not set in configuration, generated links may be incorrect
2013-06-17 18:01:12,343 Trac[main] DEBUG: Dispatching <RequestWithSession "GET '/report'">
2013-06-17 18:01:12,345 Trac[session] DEBUG: Retrieving session for ID u'leclerc'
2013-06-17 18:01:12,346 Trac[main] DEBUG: Negotiated locale: None -> fr
2013-06-17 18:01:12,351 Trac[api] WARNING: Unable to find repository '(default)' for synchronization
2013-06-17 18:01:12,352 Trac[api] DEBUG: action controllers for ticket workflow: ['ConfigurableTicketWorkflow']
2013-06-17 18:01:12,354 Trac[chrome] DEBUG: Prepare chrome data for request
2013-06-17 18:01:12,355 Trac[perm] DEBUG: No policy allowed leclerc performing TICKET_CREATE on None
2013-06-17 18:01:12,355 Trac[perm] DEBUG: No policy allowed leclerc performing TICKET_VIEW on None
2013-06-17 18:01:12,356 Trac[perm] DEBUG: No policy allowed leclerc performing SEARCH_VIEW on None
2013-06-17 18:01:12,357 Trac[perm] DEBUG: No policy allowed leclerc performing TRAC_ADMIN on None
2013-06-17 18:01:12,357 Trac[perm] DEBUG: No policy allowed leclerc performing ACCTMGR_CONFIG_ADMIN on None
2013-06-17 18:01:12,357 Trac[perm] DEBUG: No policy allowed leclerc performing ACCTMGR_USER_ADMIN on None
2013-06-17 18:01:12,358 Trac[perm] DEBUG: No policy allowed leclerc performing TICKET_ADMIN on None
2013-06-17 18:01:12,358 Trac[perm] DEBUG: No policy allowed leclerc performing PERMISSION_GRANT on None
2013-06-17 18:01:12,358 Trac[perm] DEBUG: No policy allowed leclerc performing PERMISSION_REVOKE on None
2013-06-17 18:01:12,359 Trac[perm] DEBUG: No policy allowed leclerc performing MILESTONE_VIEW on None
2013-06-17 18:01:12,359 Trac[perm] DEBUG: No policy allowed leclerc performing VERSIONCONTROL_ADMIN on None
2013-06-17 18:01:12,359 Trac[perm] DEBUG: No policy allowed leclerc performing ROADMAP_VIEW on None
2013-06-17 18:01:12,360 Trac[perm] DEBUG: No policy allowed leclerc performing TIMELINE_VIEW on None
2013-06-17 18:01:12,360 Trac[perm] DEBUG: No policy allowed leclerc performing BROWSER_VIEW on None
2013-06-17 18:01:12,361 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:1'>
2013-06-17 18:01:12,361 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:1'>
2013-06-17 18:01:12,362 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:2'>
2013-06-17 18:01:12,362 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:2'>
2013-06-17 18:01:12,362 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:3'>
2013-06-17 18:01:12,363 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:3'>
2013-06-17 18:01:12,363 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:4'>
2013-06-17 18:01:12,363 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:4'>
2013-06-17 18:01:12,364 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:5'>
2013-06-17 18:01:12,364 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:5'>
2013-06-17 18:01:12,364 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:6'>
2013-06-17 18:01:12,364 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:6'>
2013-06-17 18:01:12,365 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:7'>
2013-06-17 18:01:12,365 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:7'>
2013-06-17 18:01:12,365 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:8'>
2013-06-17 18:01:12,366 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:8'>
2013-06-17 18:01:12,366 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_MODIFY on <Resource u'report:9'>
2013-06-17 18:01:12,366 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_DELETE on <Resource u'report:9'>
2013-06-17 18:01:12,374 Trac[perm] DEBUG: No policy allowed leclerc performing EMAIL_VIEW on None
2013-06-17 18:01:12,473 Trac[perm] DEBUG: No policy allowed leclerc performing REPORT_CREATE on None


Not sure why the checks are not done on the /report page but seem to work fine on the /report/* pages...

comment:27 in reply to: ↑ 26 Changed 18 months ago by rjollos

Replying to Laurentlafon:

Not sure why the checks are not done on the /report page but seem to work fine on the /report/* pages...

The checks that are done on the /report page are different than the checks done on the /report/* pages. Access to a specific report is granted or denied in pre_process_request. The reports list on the /report page is modified in filter_stream. I probably mentioned already, but the ITemplateStreamFilter is very fragile, and you can see why by studying the method. If any other plugin (such as another plugin implementing ITemplateStreamFilter) or template customizations (see TracInterfaceCustomization#SiteAppearance) modify the structure of the report_list page, then the PrivateReportsPlugin may not be effective.

  • Do you have a site.html in your environment's template directory?
  • Have any of the project templates been replaced (see TracInterfaceCustomization#ProjectTemplates)? Could you just post the output of ls $TRACENV/templates?
  • Which theme are you using? Are you using ThemeEnginePlugin?
  • Is [inherit] templates_dir present in your trac.ini?
  • Does you report list page look like the one on this site (see report)?

If all else fails, maybe you could just post the HTML source (press CTRL+U while on the page) and we can see if it has the expected structure.

I will give some thought as to whether any more useful debug info can be added to filter_stream.

comment:28 follow-up: Changed 16 months ago by rjollos

Laurentlafon: Although I'm curious to know why this isn't working in your Trac installation, I think it might be more productive to just move to Trac 1.0.2 when it is released. I'm anticipating that it will be released within the next month, and a fix for t:#11176 (Fine-grained permission checks should be enforced on the Report list page) will be included. In fact, the changes for t:#11176 should be available on t:browser:1.0-stable within the next few days.

comment:29 in reply to: ↑ 28 Changed 16 months ago by rjollos

Replying to rjollos:

In fact, the changes for t:#11176 should be available on t:browser:1.0-stable within the next few days.

Changes committed to 1.0-stable and merged to trunk, see t:comment:31:ticket:11176.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.