Modify

#11051 closed defect (duplicate)

KeyError: 'ticket-workflow'

Reported by: unni Owned by: rjollos
Priority: high Component: WorkflowEditorPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a GET operation on /admin/ticket/workfloweditor, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'ticket', 'panel_id': u'workfloweditor', 'path_info': None}

User agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.43 Safari/537.31

System Information

Trac 0.12.3
Trac 0.12.3
Agilo 0.9.7
Babel 0.9.6
Docutils 0.8.1
Genshi 0.6
mod_wsgi 3.3 (WSGIProcessGroup traclocal WSGIApplicationGroup %{GLOBAL})
Pygments 1.4
pysqlite 2.6.0
Python 2.7.3 (default, Aug 1 2012, 05:25:23)
[GCC 4.6.3]
Python 2.7.3 (default, Aug 1 2012, 05:25:23)
[GCC 4.6.3]
RPC 1.1.2
setuptools 0.6
setuptools 0.6
SQLite 3.7.9
Subversion 1.7.5 (r1336830)
jQuery 1.4.4

Enabled Plugins

agilo 0.9.7
TracBurndown 1.9.2dev
Tracchildtickets 2.4.5
TracCustomFieldAdmin 0.2.8
TracDateField 1.1.0
TracTags 0.6
TracXMLRPC 1.1.2
TracXPDev 1.0
WorkflowEditorPlugin 1.1.5dev

Python Traceback

Traceback (most recent call last):
  File "/opt/trac/current/lib/python2.7/site-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/opt/trac/current/lib/python2.7/site-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/opt/trac/current/lib/python2.7/site-packages/Trac-0.12.3-py2.7.egg/trac/admin/web_ui.py", line 117, in process_request
    path_info)
  File "build/bdist.linux-x86_64/egg/workfloweditor/workfloweditor_admin.py", line 68, in render_admin_panel
    self._create_page_param(req, page_param)
  File "build/bdist.linux-x86_64/egg/workfloweditor/workfloweditor_admin.py", line 105, in _create_page_param
    section = self.config._sections['ticket-workflow']
KeyError: 'ticket-workflow'

Attachments (0)

Change History (2)

comment:1 Changed 17 months ago by rjollos

  • Owner changed from takanorig to rjollos
  • Status changed from new to assigned
  • Trac Release set to 0.12

Could you add the ticket-workflow section of your trac.ini?

comment:2 Changed 17 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #10143. Please see comments in that ticket.

Please upgrade to the latest version, and if you can reproduce the issue with the latest version, we'll reopen #10143. I was never able to reproduce the issue, so I'll need more details if you find that the issue still occurs with the latest plugin version (1.1.6-r12220).

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.