Modify

Opened 2 years ago

Closed 22 months ago

Last modified 15 months ago

#10143 closed defect (fixed)

KeyError: 'ticket-workflow'

Reported by: mohme Owned by: takanorig
Priority: normal Component: WorkflowEditorPlugin
Severity: normal Keywords:
Cc: unni Trac Release: 0.12

Description

How to Reproduce

While doing a GET operation on /admin/ticket/workfloweditor, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'ticket', 'panel_id': u'workfloweditor', 'path_info': None}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.47 Safari/536.11

System Information

Trac 0.12.3
Trac 0.12.3
Agilo 0.9.6.2
Babel 0.9.5
Docutils 0.7
FullBlog 0.1.1-r9430
Genshi 0.6
mod_wsgi 2.5 (WSGIProcessGroup trac_https_wsgi WSGIApplicationGroup %{GLOBAL})
Pygments 1.4dev-20110115
pysqlite 2.4.1
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
pytz 2008c
pytz 2008c
RPC 1.1.2
setuptools 0.6c12
setuptools 0.6c12
SQLite 3.7.3
Subversion 1.7.3 (r1242825)
jQuery 1.4.4

Enabled Plugins

agilo 0.9.6.2
backlinks N/A
backlinks-menu N/A
BatchModify 0.8.0-trac0.12
SecureSession 0.10dev-r1500
TicketImport 0.8
TracAnnouncer 0.12.1.dev
TracCaptcha 0.2.2
TracDiscussion 0.8-r9877
TracDownloads 0.3
TracFullBlogPlugin 0.1.1-r9430
TracMarkdownMacro 0.11.1
tracrpc.changeset N/A
TracTags 0.6
TracTocMacro 11.0.0.3
TracWysiwyg 0.12.0.3-r9676
TracXMLRPC 1.1.2
WorkflowEditorPlugin 1.0.4-r10056

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/admin/web_ui.py", line 117, in process_request
    path_info)
  File "/usr/local/lib/python2.5/site-packages/WorkflowEditorPlugin-1.0.4_r10056-py2.5.egg/workfloweditor/workfloweditor_admin.py", line 57, in render_admin_panel
    self._create_page_param(req, page_param)
  File "/usr/local/lib/python2.5/site-packages/WorkflowEditorPlugin-1.0.4_r10056-py2.5.egg/workfloweditor/workfloweditor_admin.py", line 94, in _create_page_param
    section = self.config._sections['ticket-workflow']
KeyError: 'ticket-workflow'

Attachments (0)

Change History (7)

comment:1 Changed 2 years ago by rjollos

  • Component changed from SELECT A HACK to WorkflowEditorPlugin
  • Owner set to takanorig

comment:2 Changed 2 years ago by rjollos

I can't reproduce. Any idea of what conditions led to this?

comment:3 Changed 23 months ago by rjollos

  • Trac Release changed from 0.11 to 0.12

comment:4 Changed 22 months ago by rjollos

I've tried removing the ticket-workflow section, but then I'm just prompted to upgrade the database and the default workflow is restored. I can't see how ticket-workflow could be missing from trac.ini. If you have any hints, please let me know. I do have a small change to make which should prevent the error in the case that the section is missing from trac.ini. I'll commit that and close this ticket, but please follow-up if you can.

comment:5 Changed 22 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

(In [12217]) Fixes #10143:

  • Replaced access of the private field _sections in the Configuration object with proper access to the keyed item. The issue described in #10143 has not been reproduced, but this change should avoid a traceback if there is a case in which the ticket-workflow section is missing from trac.ini, because an empty Section object is constructed in the Configuration class under this scenario.
  • Applied formatting changes to setup.py.

comment:6 Changed 15 months ago by rjollos

  • Cc unni added

#11051 closed as a duplicate, with the recommendation to upgrade to 1.1.6-r12220.

comment:7 Changed 15 months ago by rjollos

#11097 closed as a duplicate, with the recommendation to upgrade to 1.2.0-r13032.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from takanorig. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.