Modify

#11097 closed defect (duplicate)

KeyError: 'ticket-workflow'

Reported by: kpierson Owned by: takanorig
Priority: normal Component: WorkflowEditorPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

How to Reproduce

While doing a GET operation on /admin/ticket/workfloweditor, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'cat_id': u'ticket', 'panel_id': u'workfloweditor', 'path_info': None}

User agent: Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0

System Information

Trac 0.12.3
Trac 0.12.3
Agilo 0.9.6.2
Babel 0.9.5
Docutils 0.7
FullBlog 0.1.1-r9430
Genshi 0.6
mod_wsgi 2.5 (WSGIProcessGroup trac_wsgi_02 WSGIApplicationGroup %{GLOBAL})
Pygments 1.4dev-20110115
pysqlite 2.4.1
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
Python 2.5.2 (r252:60911, Jan 24 2010, 18:02:01)
[GCC 4.3.2]
pytz 2008c
pytz 2008c
RPC 1.1.2
setuptools 0.6c12
setuptools 0.6c12
SQLite 3.7.3
Subversion 1.7.8 (r1419691)
jQuery 1.4.4

Enabled Plugins

agilo 0.9.6.2
backlinks N/A
backlinks-menu N/A
customroadmap.webadminui N/A
SecureSession 0.10dev-r1500
TicketImport 0.8
TracAnnouncer 0.12.1.dev
TracCaptcha 0.2.2
TracCustomRoadmap 0.4
TracDiscussion 0.8-r9877
TracDownloads 0.3
TracFullBlogPlugin 0.1.1-r9430
TracMarkdownMacro 0.11.1
tracrpc.changeset N/A
TracTags 0.6
TracTocMacro 11.0.0.3
TracWysiwyg 0.12.0.3-r9676
TracXMLRPC 1.1.2
WorkflowEditorPlugin 1.0.4-r10056

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.5/site-packages/Trac-0.12.3-py2.5.egg/trac/admin/web_ui.py", line 117, in process_request
    path_info)
  File "/usr/local/lib/python2.5/site-packages/WorkflowEditorPlugin-1.0.4_r10056-py2.5.egg/workfloweditor/workfloweditor_admin.py", line 57, in render_admin_panel
    self._create_page_param(req, page_param)
  File "/usr/local/lib/python2.5/site-packages/WorkflowEditorPlugin-1.0.4_r10056-py2.5.egg/workfloweditor/workfloweditor_admin.py", line 94, in _create_page_param
    section = self.config._sections['ticket-workflow']
KeyError: 'ticket-workflow'

Attachments (0)

Change History (1)

comment:1 Changed 14 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10143, and fixed in [12217]. Please upgrade to 1.2.0-r13032.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from takanorig. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.