Modify

#11099 closed defect (invalid)

workflow diagram isn't shown

Reported by: andrex Owned by: jun66j5
Priority: normal Component: TracWorkflowAdminPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

Hi. I installed the plugin and graphviz, then went to admin/ticket/workflowadmin, but no workflow diagram was shown. My browser reported that /chrome/site/tracworkflowadmin/2e45cf18304f82a32a34035751e7d02d.png was not found.

I looked in my Trac htdocs directory, and found that the tracworkflowadmin directory was in htdocs, not in htdocs/site. Apparently in my Trac installation, /chrome/site is served from htdocs/site, not from htdocs. So htdocs/tracworkflowadmin is in the wrong place. I made a symlink from htdocs/site/tracworkflowadmin to ../tracworkflowadmin, and that fixed the problem.

I can't tell if this is a misconfiguration on my part. In my pre-1.0 Trac installations, /chrome/site was served from htdocs, but now in 1.0 it seems that it's changed to htdocs/site. I can't find any setting in trac.ini that specifies that, so it seems just to have been a change in 1.0. If that's true, then the plugin will need to change where it puts the tracworkflowadmin directory in 1.0.

Attachments (0)

Change History (1)

comment:1 Changed 19 months ago by andrex

  • Resolution set to invalid
  • Status changed from new to closed

Yes, this seems to have been a misconfiguration on my part. I adjusted the web server alias for /chrome/site to point to htdocs, and now htdocs/tracworkflowadmin is in the right place.

Sorry for the noise.

Add Comment

Modify Ticket

Action
as closed The owner will remain jun66j5.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.