Modify

#11100 closed defect (duplicate)

static link not working

Reported by: typek_pb Owned by: rjollos
Priority: low Component: TracTicketStatsPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I'm running trac 1.0.1 with trunk version of TracTicketStatsPlugin installed today (20.5.2013) via:

sudo easy_install http://trac-hacks.org/svn/tracticketstatsplugin/trunk/

After trying to retrieve Static URL copied from the month view (http://192.168.2.114:8000/ticketstats?content=render&start_date=11/21/2012&end_date=05/20/2013&resolution=30&milestone=sprint 1), I got following error on page:

Trac detected an internal error:
AttributeError: 'list' object has no attribute 'find'

And in the console I've seen:

2013-05-20 14:16:55,192 Trac[main] ERROR: Internal Server Error: 
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Tracticketstats-3.0.0dev_r0-py2.7.egg/ticketstats/ticketstats.py", line 154, in process_request
    milestone_num = milestone_list.find(milestone)
AttributeError: 'list' object has no attribute 'find'
2013-05-20 14:16:55,193 Trac[perm] DEBUG: No policy allowed pb performing EMAIL_VIEW on None
192.168.2.111 - - [20/May/2013 14:16:55] "GET /ticketstats?content=render&start_date=11/21/2012&end_date=05/20/2013&resolution=30&milestone=sprint%201 HTTP/1.1" 500 -

However month view chart was generated correctly when going over Main menu -> Ticket stats

Attachments (0)

Change History (2)

comment:1 Changed 14 months ago by typek_pb

  • Priority changed from normal to low

Now I got it, problem seem to be in the space in my milestone name ("spring 1"), when going for:

http://192.168.2.114:8000/ticketstats?content=render&start_date=11/21/2012&end_date=05/20/2013&resolution=30&milestone=sprint%1 

rather than:

http://192.168.2.114:8000/ticketstats?content=render&start_date=11/21/2012&end_date=05/20/2013&resolution=30&milestone=sprint 1

it got solved.
So maybe static URL should do proper URL encoding to make sure it's usable.

comment:2 Changed 14 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for reporting. This is a duplicate of #8300, and I will try to get it fixed today.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.