Modify

Opened 8 months ago

Closed 8 months ago

Last modified 7 months ago

#11284 closed defect (invalid)

Assert Failed

Reported by: rdown@… Owned by: coling
Priority: high Component: ClientsPlugin
Severity: blocker Keywords:
Cc: rjollos, rdown@… Trac Release: 1.0

Description

How to Reproduce

While doing a GET operation on /admin/ticket/clients/Test, Trac issued an internal error.

Created a test client, and attempted to view the details

Request parameters:

{'cat_id': u'ticket', 'panel_id': u'clients', 'path_info': u'Test'}

User agent: #USER_AGENT#

System Information

Trac 1.0
Docutils 0.9.1
Genshi 0.6 (without speedups)
GIT 1.8.3.4
Pygments 1.5
pysqlite 2.6.0
Python 2.7.1 (r271:86832, Jul 31 2011, 19:30:53)
[GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)]
setuptools 0.6
SQLite 3.7.7
jQuery #JQUERY#

Enabled Plugins

clients 0.5dev-r12092
TracAccountManager 0.4.3
TracHierWiki 1.0
WorkflowEditorPlugin 1.2.0dev-r13032

Python Traceback

Traceback (most recent call last):
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/web/main.py", line 233, in dispatch
    content_type)
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/web/chrome.py", line 1000, in render_template
    encoding='utf-8')
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/core.py", line 183, in render
    return encode(generator, method=method, encoding=encoding, out=out)
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/output.py", line 58, in encode
    for chunk in iterator:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/output.py", line 339, in __call__
    for kind, data, pos in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/output.py", line 826, in __call__
    for kind, data, pos in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/output.py", line 670, in __call__
    for kind, data, pos in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/output.py", line 771, in __call__
    for kind, data, pos in chain(stream, [(None, None, None)]):
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/output.py", line 586, in __call__
    for ev in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/web/chrome.py", line 1126, in _generate
    for kind, data, pos in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/markup.py", line 378, in _match
    ctxt, start=idx + 1, **vars):
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/markup.py", line 327, in _match
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/markup.py", line 327, in _match
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/core.py", line 288, in _ensure
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/path.py", line 588, in _generate
    subevent = next()
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/base.py", line 605, in _include
    for event in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/markup.py", line 316, in _strip
    event = next()
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/base.py", line 545, in _flatten
    for kind, data, pos in stream:
  File "/Library/Python/2.7/site-packages/Genshi-0.6-py2.7.egg/genshi/template/directives.py", line 366, in __call__
    for item in iterable:
  File "/Library/Python/2.7/site-packages/clients-0.5dev_r12092-py2.7.egg/clients/events.py", line 231, in select
    clev._load_options(client, db)
  File "/Library/Python/2.7/site-packages/clients-0.5dev_r12092-py2.7.egg/clients/events.py", line 138, in _load_options
    self.action_options = self._load_client_options(None, 'action', db)
  File "/Library/Python/2.7/site-packages/clients-0.5dev_r12092-py2.7.egg/clients/events.py", line 113, in _load_client_options
    assert thing is not None, 'Invalid action'
AssertionError: Invalid action

Attachments (0)

Change History (5)

comment:1 Changed 8 months ago by rdown

  • Cc rdown@… added

comment:2 Changed 8 months ago by rdown

  • Resolution set to invalid
  • Status changed from new to closed

comment:3 Changed 8 months ago by rjollos

Solved it? What was the issue?

comment:4 Changed 8 months ago by rdown

Yup, it was a user error.... I forgot to add the plugin to the components list in my trac.ini...... I installed it late at night......

comment:5 Changed 7 months ago by rjollos

It seems like a design flaw that the plugin is getting called when the Plugin's Components are not enabled. I suppose that is because ClientEvent isn't a component, but I haven't looked into where ClientEvent is instantiated.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coling. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.