Modify

Opened 7 months ago

Closed 7 months ago

#11571 closed enhancement (fixed)

Roadmap shouldn't show closed projects

Reported by: endquote Owned by: falkb
Priority: normal Component: SimpleMultiProjectPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

The roadmap page shows all projects, including closed ones. It would be best if closed projects weren't shown.

Interestingly, the "filter projects" list on the right side only shows open projects.

Attachments (0)

Change History (9)

comment:1 Changed 7 months ago by falkb

What did you choose in the "filter projects" list? What is your URL in the browser address line?

comment:2 Changed 7 months ago by endquote

Nothing is chosen in the filter list, but the only options there are open projects. But the main roadmap list shows all milestones for all projects. I'm at http://trac/roadmap.

comment:3 Changed 7 months ago by falkb

OK, I can reproduce it. I always selected one or more entries in that list, and that's why did not see that bug... ;)

comment:4 Changed 7 months ago by falkb

  • Status changed from new to accepted

if the latest used project-filter setting was "All", it will show the closed projects also, and this should not happen.

comment:5 Changed 7 months ago by falkb

In 13670:

Refs #11571: don't show closed projects also if project-filter is even set to "All" (because "All" means all currently open projects)

comment:6 Changed 7 months ago by falkb

  • Keywords testing added

Please test [13670]!

  • If you set the project-filter to "All" (and this is Trac default), it wont show the closed projects now.
  • If you set the project-filter or URL to any different project or combination of projects, it will show that even if it's a closed project, and this is desired this way to have a chance to look at those closed ones also.

=> The latest project-filter setting is always stored to the user session; which means if you click on the main menu item "Roadmap" (or you call <tracURL>/roadmap), it'll remember and use that setting from the Trac user session.

comment:7 Changed 7 months ago by endquote

I gave this a shot -- closed projects are no longer appearing for me.

From your description above it looks like there is a way to show milestones for closed projects, but I wasn't able to do that. I clicked "all" in the filter list and tried /roadmap?filter-projects=myclosedproject but it didn't appear.

comment:8 Changed 7 months ago by falkb

Yes, if you've stored a link or bookmark to a project for example in your wiki, it'll still work and leads you to the project even if it was closed. I created a wiki page showing a table of project links (as archive), and I use that to visit projects, and it works even for the closed ones.

comment:9 Changed 7 months ago by falkb

  • Keywords testing removed
  • Resolution set to fixed
  • Status changed from accepted to closed

a filter called 'myclosedproject' doesn't exist. :)

I think we can close this one now since it's been tested for you and me.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.