Modify

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#11680 closed task (duplicate)

Disable emails when submitting hour entries

Reported by: jared.bownds@… Owned by: hasienda
Priority: high Component: AnnouncerPlugin
Severity: blocker Keywords: notification, hours,
Cc: Trac Release: 1.0

Description (last modified by rjollos)

We are blocked from adopting AnnouncerPlugin because using it in conjunction with TracHoursPlugin proves problematic. AnnouncerPlugin will generate a notification when an hour entry is submitted via the /hours form. In contrast, Trac's core notification system ignores hour entries made via the /hours form and does not send a notification. Is there a patch that can be implemented to resolve this issue?

Attachments (0)

Change History (4)

comment:1 follow-up: Changed 4 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

The hours entry is stored in a custom field. Effectively what you are asking for is to mute email notifications when the only change is to a ticket custom field. I believe this request is a duplicate of #10482, so I'll close this ticket as a duplicate.

However your claim that Trac's core notification system doesn't send a notification does not seem consistent with the behavior that I'm familiar with. Trac will send a notification when only ticket properties are changed. Most likely you have some combination of [notification] always_notify_reporter, [notification] always_notify_owner and [notification] always_notify_updater (TracIni#notification-section) that prevented a notification from being sent.

comment:2 Changed 4 months ago by rjollos

  • Description modified (diff)

comment:3 in reply to: ↑ 1 ; follow-up: Changed 4 months ago by jared.bownds@…

Replying to rjollos:

The hours entry is stored in a custom field. Effectively what you are asking for is to mute email notifications when the only change is to a ticket custom field. I believe this request is a duplicate of #10482, so I'll close this ticket as a duplicate.

Okay, good to know.

However your claim that Trac's core notification system doesn't send a notification does not seem consistent with the behavior that I'm familiar with. Trac will send a notification when only ticket properties are changed. Most likely you have some combination of [notification] always_notify_reporter, [notification] always_notify_owner and [notification] always_notify_updater (TracIni#notification-section) that prevented a notification from being sent.

At either rate, notifications are muted when entering hours via the hours form. As a result, no one on the ticket receives a notification. Moreover, if this phenomenon was due to a combination if [notification] configurations, would this same configuration be effective for AnnouncerPlugin as well? This is not the case in my experience using the AnnouncerPlugin.

comment:4 in reply to: ↑ 3 Changed 4 months ago by rjollos

Replying to jared.bownds@…:

Moreover, if this phenomenon was due to a combination if [notification] configurations, would this same configuration be effective for AnnouncerPlugin as well?

The AnnouncerPlugin has subscription preferences, as well as similar options: [announcer] always_notify_owner, [announcer] always_notify_reporter, [announcer] always_notify_cc.

Now that I think about it though, I think the issue is that AnnouncerPlugin uses resource change listeners, so it will notify whenever a ticket is changed, whereas the old Trac notification system depended on an explicit method call to send the notification, and the method is not called when editing hours from the /hours form. So I think your findings that the Trac notification system doesn't send change notifications is what should be expected, and we need finer-grain control over the AnnouncerPlugin notifications in order to suppress them.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.