Modify

Opened 8 years ago

Closed 7 years ago

#1182 closed defect (duplicate)

'BatchModifyModule' object has no attribute 'get_htdocs_dirs'

Reported by: anonymous Owned by: ashwin_phatak
Priority: normal Component: BatchModifyPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description (last modified by coderanger)

In my Logfile and in the Source Code I get messages like:

Traceback (most recent call last):
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "C:\Python24\Lib\site-packages\trac\web\main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "C:\Python24\Lib\site-packages\trac\web\chrome.py", line 225, in process_request
    for dir in [os.path.normpath(dir[1]) for dir
AttributeError: 'BatchModifyModule' object has no attribute 'get_htdocs_dirs'

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by coderanger

#1185 has been marked as a duplicate of this ticket.

comment:2 Changed 8 years ago by coderanger

  • Description modified (diff)

Fixing formatting.

comment:3 Changed 8 years ago by ostolop

This patch fixes things.

*** web_ui.py.orig      2007-04-11 13:55:34.707121000 +0100
--- web_ui.py   2007-04-11 13:56:08.651284000 +0100
***************
*** 55,60 ****
--- 55,63 ----
  
      # ITemplateProvider methods
  
+     def get_htdocs_dirs(self):
+         return []
+ 
      def get_templates_dirs(self):
          from pkg_resources import resource_filename
          return [resource_filename(__name__, 'templates')]

comment:4 Changed 7 years ago by coling

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1337 (now fixed)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.