Modify

Opened 7 years ago

Closed 4 years ago

#1336 closed defect (wontfix)

AttributeError: 'NoneType' object has no attribute 'get'

Reported by: prasand Owned by: mgood
Priority: normal Component: TracPygmentsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

This error isn't critical, but it's logged on every page load. The output of the error is:

2007-03-14 23:28:47,075 Trac[main] ERROR: 'NoneType' object has no attribute 'get'
Traceback (most recent call last):
  File "/home/username/packages/lib/python2.3/site-packages/trac/web/main.py", line 252, in dispatch
    self._post_process_request(req)
  File "/home/username/packages/lib/python2.3/site-packages/trac/web/main.py", line 269, in _post_process_request
    content_type)
  File "build/bdist.linux-i686/egg/tracpygments/__init__.py", line 133, in post_process_request
AttributeError: 'NoneType' object has no attribute 'get'

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by giel

This is fixed by the patch in #1944.

comment:2 Changed 6 years ago by giel

#2195 is another duplicate of this bug.

comment:3 Changed 4 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

Closing ticket since plugin is unmaintained and support can be found by upgrading to Trac 0.11.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.