Modify

Opened 8 years ago

Closed 8 years ago

#208 closed enhancement (duplicate)

Edit Section

Reported by: d3matt Owned by: anybody
Priority: normal Component: Request-a-Hack
Severity: normal Keywords:
Cc: Trac Release: 0.8

Description

MediaWiki has the ability to edit only a section of an article. How hard would it be to get this implemented in trac? Personally, I would use MediaWiki, but I'm new at my job, and they've been using trac for awile.

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by d3matt

  • Type changed from defect to enhancement

comment:2 Changed 8 years ago by coderanger

Something like this would be very hard to implement as a plugin, just beacuse the wiki system offers no extension point for such a thing, though it might be possible to make a patch against the existing wiki system. My personal preference is that if a page is big enough that you need to worry about editing it in sections, you might want to break it up into smaller sub-pages.

comment:3 Changed 8 years ago by d3matt

That's kind of what I figured. What would it take to get edgewall to implement something like this?

comment:4 Changed 8 years ago by d3matt

Hey, how hard would it be to do this on the client side? Where a bit of javascript puts everything before the section in one variable, the section goes in an edit box, and everything goes in another variable. I haven't looked at the wiki code, but how hard would it be to do something like that?

comment:5 Changed 8 years ago by coderanger

The issue is that there is not really a good way (without patching) to alter the wiki web interface.

comment:6 Changed 8 years ago by coderanger

This has been cross listed as #T2867.

comment:7 Changed 8 years ago by athomas

  • Resolution set to duplicate
  • Status changed from new to closed
  • Trac Release set to 0.8

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from anybody. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.