Modify

Opened 7 years ago

Closed 6 years ago

#2176 closed defect (fixed)

Tracpasteplugin does not work with Trac 0.11 r 6153 (Context)

Reported by: nulleke@… Owned by: mitsuhiko
Priority: normal Component: TracPastePlugin
Severity: normal Keywords: Context api
Cc: Trac Release: 0.11

Description

Tracpaste plugin does not work with the latest trac (r6153) because Context is not defined anymore in trac.wiki.api.

Attachments (1)

TracPaste-r2887.diff (1.7 KB) - added by mrb@… 7 years ago.
patch to make plugin work with newerr Trac (tested on r6326)

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by mrb@…

patch to make plugin work with newerr Trac (tested on r6326)

comment:1 Changed 6 years ago by anonymous

To use you should download the patch as a raw file, then cd to the 0.11 directory. Run patch -p0 < TracPaste-r2887.diff and then proceed to build the egg/install.

comment:2 Changed 6 years ago by aphukan@…

Hi,

I tried using your patch. I built the egg and tried installing it via web admin, but still can't get the module to work.

Any updates would be nice.

Regards,
Amit.

comment:3 Changed 6 years ago by otaku42

I can confirm that the patch works as intended on Trac 0.11-stable r7613.

comment:4 Changed 6 years ago by osimons

Yup, the patch works but the lines changing the cursor are not needed. The pygments and context changes are sorely needed though...

I was all set to commit the patch as I was sure I got granted commit rights to the plugin quite some time ago. That seems not to be the case now, so give me a day and I'll get it committed.

comment:5 Changed 6 years ago by osimons

  • Resolution set to fixed
  • Status changed from new to closed

(In [4776]) TracPastePlugin: Fix to make it work with Trac 0.11. Patch by nulleke@... (minus som cursor lines that don't seem necessary to change).

Closes #2176.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mitsuhiko. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.