Modify

Opened 6 years ago

Closed 6 years ago

#2178 closed defect (duplicate)

error when renaming a page with existing link (NameError: global name 'sre' is not defined)

Reported by: vadim@… Owned by: coderanger
Priority: high Component: WikiRenamePlugin
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

Tried renaming a page, unsuccessfylly. Got the following error:

Trac detected an internal error:
    NameError: global name 'sre' is not defined

I'll try to reproduce the trace here (can't directly cut/paste, unfortunately):

.../python2.5/site-packages/Trac-0.11dev_r6049-py2.5.egg/trac/web/main.py:381 in dispatch_request
.../python2.5/site-packages/Trac-0.11dev_r6049-py2.5.egg/trac/web/main.py:191 in dispatch
.../python2.5/site-packages/Trac-0.11dev_r6049-py2.5.egg/trac/admin/web_ui.py:108 in process_request
.../build/bdist.linux-x86_64/egg/wikirename/web_ui.py:35 in render_admin_panel
.../build/bdist.linux-x86_64/egg/wikirename/util.py:85 in rename_page

Note that this seems to happen when there's an existing link that needs to be updated. That is, if there's an existing link of the form [wiki:OldName blah blah] .
Renaming seems to work fine with links like [OldName blah blah] and OldName , but if I understand correctly, the latter two are simply not recognized as links by this plugin. Changing the link style does not always help (it helped in a test page I created, but not in the original culprit page).

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #1903

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.