Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#2791 closed defect (worksforme)

ChangeLog for 0.11 does not work

Reported by: jouvin@… Owned by: athomas
Priority: highest Component: ChangeLogMacro
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

Hi,

When using the last ChangeLog for 0.11 (r2942), it doesn't work properly. It displays :

<pre>template/branches/glite-3.1,20</pre>

when called with :

[[ChangeLog(template/branches/glite-3.1,20)]]

The same call is working properly under 0.10.

Attachments (0)

Change History (9)

comment:1 Changed 6 years ago by anonymous

  • Priority changed from normal to highest
  • Severity changed from normal to critical

comment:2 Changed 6 years ago by anonymous

:( It doesn't work for Trac 0.11.
The errors are like this -

Trac detected an internal error:

TypeError: previous_rev() takes exactly 2 arguments (3 given)

comment:3 Changed 6 years ago by mikon

A very minor and probably OOF remark: it does not install in 0.11 with easy_install, unlike so many other plugins.

mko@trac:~$ sudo easy_install http://trac-hacks.org/svn/changelogplugin/0.11
Downloading http://trac-hacks.org/svn/changelogplugin/0.11
Doing subversion checkout from http://trac-hacks.org/svn/changelogplugin/0.11 to /tmp/easy_install-hS1LVe/0.11
Processing 0.11
error: Couldn't find a setup script in /tmp/easy_install-hS1LVe/0.11

comment:4 Changed 6 years ago by athomas

  • Resolution set to worksforme
  • Status changed from new to closed

The latest changelog plugin works for me under latest Trac trunk.

As for the easy_install, this plugin is a single-file plugin. Just copy it into Trac's "plugin" directory.

comment:5 Changed 6 years ago by mikon

Works for me too (0.11).

Totally OOT, about easy_install: I (will) have tens of projects and while the .egg plugins I need to install just once, the one-file plugins don't work out of /usr/lib/python2.5/site-packages, so I need to put them into each project's plugins directory. Unless I'm missing something. I may make the plugins directories symlinks, but then I lose the possibility of single-project plugins.

comment:6 Changed 6 years ago by mikon

OK, I've found the

[inherit]
plugins_dir = ...
}}

hack, moved ChangeLogPlugin there and it works OK installed in the global plugins directory, too. Thanks for your work.

comment:7 Changed 6 years ago by jouvin@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I still have the same problem after upgrading to last changelog.py and last 0.11-stable (r7502)...

Thanks in advance for any hint...

Michel

comment:8 Changed 6 years ago by perreko

  • Resolution set to worksforme
  • Status changed from reopened to closed

I thinks it is not a bug, it's an error in the documentation;

Where it says "In your trac.ini, tracchangelog.* = enabled", should say "In your trac.ini, changelog.* = enabled"

comment:9 Changed 4 years ago by rjollos

  • Component changed from ChangeLogPlugin to ChangeLogMacro

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.