Modify

Opened 6 years ago

Closed 21 months ago

#2901 closed defect (worksforme)

Getting UnicodeDecodeError: when trying to view the the doxyfiles

Reported by: tomas@… Owned by: cboos
Priority: normal Component: DoxygenPlugin
Severity: blocker Keywords: needinfo
Cc: Trac Release: 0.12

Description (last modified by rjollos)

UnicodeDecodeError: 'ascii' codec can't decode byte 0xf6 in position 712: ordinal not in range(128)

How to Reproduce ¶

While doing a GET operation on /doxygen/, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'action': 'index', 'path': ''}

System Information ¶
Trac 	0.11b1
Python 	2.4.3 (#1, Mar 14 2007, 18:51:08)
[GCC 4.1.1 20070105 (Red Hat 4.1.1-52)]
setuptools 	0.6c8
SQLite 	3.3.6
pysqlite 	1.1.7
Genshi 	0.4.4
Pygments 	0.9
Subversion 	1.4.2 (r22196)

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py", line 398, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/Trac-0.11b1-py2.4.egg/trac/web/main.py", line 195, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/doxygentrac/doxygentrac.py", line 170, in process_request
  File "build/bdist.macosx-10.3-fat/egg/genshi/core.py", line 342, in __new__
UnicodeDecodeError: 'ascii' codec can't decode byte 0xf6 in position 712: ordinal not in range(128)

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by anonymous

  • Severity changed from normal to blocker

Don't know if I put the severity correct, since the plug-in is un-usable and doesn't work at all

comment:2 Changed 6 years ago by anonymous

  • Trac Release changed from 0.10 to 0.11

comment:3 Changed 6 years ago by cboos

  • Keywords needinfo added

Can you verify whether r3737 fixed the issue? If not, please send an update traceback (enclosed within a {{{ ... }}} block please!)

comment:4 Changed 4 years ago by anonymous

getting same error after fresh installation of newest doxygen plugin

comment:5 Changed 4 years ago by thomas.bouffon@…

  • Trac Release changed from 0.11 to 0.12

Hi,
In case it might help : I used to have the same error because the default index page for the plugin is main.html whereas it is index.html for the doxygen-generated pages.
Adding index=index.html solved the issue

comment:6 Changed 21 months ago by rjollos

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce with the latest 0.11 branch code, and this ticket has been open for a long time. Please reopen if you continue to have trouble with the latest trunk and can provide more info.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from cboos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.