Modify

Opened 6 years ago

Last modified 19 months ago

#3089 new defect

"Stop Work" behavior not compatible with IE7 & FF3

Reported by: ian Owned by: coling
Priority: high Component: WorkLogPlugin
Severity: major Keywords: IE7, Customization
Cc: aexl Trac Release: 0.11

Description

Hello,

I really like your Trac plugin. I'm currently exploring using it for time tracking for my Java development team.

In WorkLogPlugin 0.10 the "Stop Work" behavior was much simpler (a text field) however due to a div positioning issue the box was overlapping the navigation bar in IE7.

In WorkLogPlugin 0.11 I notice you added a fancy effect where the screen goes dark and you can enter a comment and choose the date/time you stopped work. This also has issues in IE7 (you can't enter anything in the text field). Also, the textarea overlaps the edge of the box.

This makes it impossible to use the Stop Work button in IE7 which significantly hampers the usability of the plugin.

Would it be possible to have an admin option to choose which style of Stop Work comments is used (if any)?

Personally I much prefer the 0.10 implementation (much simpler). If the div positioning issue could be resolved I would say it perfectly meets our needs.

I'm not a big fan of the screen-dimming effect in 0.11 and if I could disable I would.

I think subtlety works best here. Think of the idea of timer - you click to turn it on, and click again to turn it off. Having a dialog box pop up is a bit counter-intuitive.

Other than that, I would maybe suggest that the "Record Time via Time and Estimation" option be enabled by default.

Keep up the good work!

Ian

Attachments (3)

Trac_WorkLog_bug.jpg (28.1 KB) - added by f.fracssi@… 6 years ago.
Worklog Bug with Themes
worklog_stop.html (2.9 KB) - added by aexl 5 years ago.
jqModal.css (1.3 KB) - added by aexl 5 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 years ago by coling

  • Status changed from new to assigned

Thanks for the encouragement Ian! :)

There will be further changes in the before the "final" 0.11 version. I am going to integrate the time tracking with the new Workflow models that are available in 0.11. This means that I can in theory do away with the start and stop work buttons completely (although I may keep them as kinda shortcuts as I'm quite used to them (and it's nice they are at the top of the page!) although I may do something totally different to achieve the same end goal).

Sadly the text area was only ever temporary as I needed a way to allow the user to pick a date/time in the past if they accidentally "over worked" themselves - e.g. go home having forgotten to click "stop work" in eagerness to get out of the office ;)). This is why this dialog is bigger - it's not just about the text box. I've not fiddled with the CSS in IE7 but if you want to tweak it, it should be fairly obvious (there is only one CSS file) and I'll happily apply any patch that doesn't (adversely) affect my normal browsers (Firefox and Safari).

I will probably change the popup tho, so that it's not needed and that a more dynamic system will be included lower down in the form next to the regular state transition stuff if you tick a box or something, so all in all, I wouldn't bother and this will probably be "fixed" by other means in due course!

comment:2 Changed 6 years ago by ian

Hello,

That sounds good. I'm really looking forward to seeing the next version of your plugin. I could start using this right away if the 'stop work' usability was improved even just a bit.

If you need a beta tester, I would be happy to try out the next version and give you some feedback.

Please consider my vote for the "classic" stop button you had before. It was really nice (especially with the simple text field). If you restore it (or provide an option to restore it) then I can look into the CSS issues in IE7. (I can't test the 0.10 version anymore since I upgraded to Trac 0.11).

I agree that custom ticket fields is the way to go for entering/editing time (in addition to the box at top of the screen - I really like that).

Thanks again!

Ian

comment:3 Changed 6 years ago by f.fracssi@…

  • Summary changed from "Stop Work" behavior not compatible with IE7 to "Stop Work" behavior not compatible with IE7 & FF3

I get the same (mis-)behaviour with FF3.
Is there a fix or workaround, because I'd
really like to use this plugin.

comment:4 Changed 6 years ago by coling

It works fine for me in FF3. I use it all the time :s

Sadly upstream Trac folks are not answering a rather complex query I have right now about how to proceed with this plugin so I've hit a bit of a brick wall. While I wait for an answer, I'll try and find time to make the stop work thing work with IE7 (but like I say it works fine for me on FF3 so that bit is confusing :s).

Changed 6 years ago by f.fracssi@…

Worklog Bug with Themes

comment:5 Changed 6 years ago by anonymous

OK, I have investigated a bit further, and found the culprit. I am normally using the PyDotOrg Theme (using the ThemeEnginePlugin). If I use the default Theme it works fine.

The problem is that the Popup gets dark, too and you may not enter any data there (see screenshot). The only way to get out of this is the browsers back button.

comment:6 Changed 6 years ago by anonymous

  • Cc info@… removed

comment:7 Changed 6 years ago by anonymous

In FF3, and I'm guessing IE7, though I haven't verified it, the problem has to do with the z-index handling of embedded div's. The jqmOverlay div is at the top level, so it's z-index of 2999 is respected, but the workLogPopup, at least in my theme, is contained within a bodyContent div (and a couple other div's), so it is rendered below the jqmOverlay. Well, I'm assuming that's why it's rendered below the jqmOverlay. I don't really have any time to look into this more right now. I did try changing the position style of workLogPopup to fixed and absolute, neither of which seemed to have any effect.

comment:8 Changed 5 years ago by aexl

  • Cc trac@… added

i also face the timer-box-too-big problem.

(bytheway: great work!!!)

comment:9 Changed 5 years ago by aexl

  • Cc aexl added; trac@… removed
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:10 Changed 5 years ago by aexl

  • Resolution fixed deleted
  • Status changed from closed to reopened

sry

comment:11 Changed 5 years ago by aexl

  • Status changed from reopened to new

comment:12 Changed 5 years ago by anonymous

quick fix:

  • in htdocs/worklog/jqModal.css line 14 change "top" position from 17% to say 2%

this fixes the issue for my desktop, but not for my netbook...

a more thorough fix changes templates/worklog_stop.html so that submit button is on top (and then i would prefer calendar above comment, but ymmv).
i tried this but even after rebuilding the egg and restarting apache the template seemed not to change, i might face some egg cache isues that i dont understand.

have fun!

Changed 5 years ago by aexl

Changed 5 years ago by aexl

comment:13 Changed 19 months ago by pehas

I'm experiencing the same issue with Chrome.

Shame, it is really interesting and useful plugin which I can't use in full due to this issue..

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.