Modify

Opened 6 years ago

Closed 6 years ago

#3516 closed defect (duplicate)

Page navigator with wrong URL when the result from a report has more than 100 records.

Reported by: anebi Owned by: bobbysmith007
Priority: high Component: TimingAndEstimationPlugin
Severity: major Keywords: page navigator
Cc: Trac Release: 0.11

Description

From management screen when click on some report t outpout the results (100 per page). If the results are more than 100, then on the top of the page appear page naviator (2,3,4,5 etc.). When we click on page 2 for example, the url is changing this way: h t t p : / / mydomain.com/trac/project/report/12?page=2

On page 1 the url looks this way:
h t t p s : / / mydomain.com/trac/project/report/12?BILLABLE=0&UNBILLABLE=0&ASSIGNED=assigned&CLOSED=closed&NEW=new&REOPENED=reopened&STARTDATE=0&ENDDATE=2000000000

The page 2 and the rest (also <- and -> buttons) should have this url:

h t t p s : / / mydomain.com/trac/project/report/12?page=2&BILLABLE=0&UNBILLABLE=0&ASSIGNED=assigned&CLOSED=closed&NEW=new&REOPENED=reopened&STARTDATE=0&ENDDATE=2000000000

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by bobbysmith007

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #3508

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from bobbysmith007. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.