Modify

Opened 6 years ago

Closed 2 years ago

#3882 closed enhancement (duplicate)

Add partial wiki page section include

Reported by: anonymous Owned by: coderanger
Priority: normal Component: IncludeMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

It'd be useful to include sections within a wiki page from a different page.

Something like:

[[Include(wiki:Page/Subpage#Section)]]

Attachments (1)

includeSectionOnlyPatch.diff (3.3 KB) - added by suddani@… 3 years ago.
patch for partial inclusion

Download all attachments as: .zip

Change History (3)

comment:1 Changed 3 years ago by suddani@…

added a patch that allows this behaviour and as well adds all section lower in the graph

Besides that you can aswell match for regex directly in the wiki page with

[[Include(wiki:Page@/RegEx/)]]

Changed 3 years ago by suddani@…

patch for partial inclusion

comment:2 Changed 2 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #9537 since #9537 has a patch. #8972 was also a duplicate.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.