Modify

Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#4364 closed enhancement (duplicate)

SQL for report to sort tickets based on number of votes

Reported by: lschiere Owned by: rjollos
Priority: normal Component: VotePlugin
Severity: normal Keywords:
Cc: grone Trac Release: 0.11

Description

It would be awesome if you could sort tickets based on the number of votes they have received.

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by anonymous

what about his ticket? There you find a sample SQL query #3655

comment:2 Changed 6 years ago by anonymous

here is some draft

SELECT ticket.id AS ticket , COUNT(votes.resource) AS vote, status, severity, priority, owner, time as created, summary

FROM ticket LEFT OUTER JOIN votes ON ('ticket/'
ticket.id = votes.resource)

WHERE ticket.status IN ('new', 'assigned', 'reopened')

GROUP BY ticket.id ORDER BY vote DESC

comment:3 Changed 5 years ago by grone

  • Cc grone added; anonymous removed

comment:4 Changed 4 years ago by rjollos

  • Owner changed from athomas to rjollos

Reassigning ticket to new maintainer.

comment:5 Changed 4 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

Duplicate of #3655.

comment:6 Changed 4 years ago by rjollos

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:7 Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:8 Changed 4 years ago by rjollos

  • Summary changed from sort tickets by votes to SQL for report to sort tickets based on number of votes

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.