Modify

Opened 5 years ago

Closed 5 years ago

#4409 closed defect (duplicate)

bug in plugin _launch method

Reported by: jholg Owned by: pkropf
Priority: normal Component: GraphvizPlugin
Severity: normal Keywords:
Cc: cboos Trac Release: 0.11

Description

The check on the input in the _launch method is wrong, which leads to preview not working correctly on graphs (you can workaround it by reloading the previewed page, iirc).
Should be changed to check on encoded_input instead.

The relevant 0.7.2 based diff portion is:

@@ -529,7 +532,7 @@ class Graphviz(Component):
             encoded_cmd.append(arg)
         p = subprocess.Popen(encoded_cmd, stdin=subprocess.PIPE,
                              stdout=subprocess.PIPE, stderr=subprocess.PIPE)
-        if input:
+        if encoded_input:
             p.stdin.write(encoded_input)
         p.stdin.close()
         out = p.stdout.read()

This looks still wrong in the 0.7.4 source.

Cheers, Holger

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by cboos

This was fixed some time ago in r4536.

Duplicate of #3912 - I should really find 5 minutes to remove that graphviz-0.7.4 folder...

comment:2 Changed 5 years ago by cboos

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from pkropf. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.