Modify

Opened 5 years ago

Closed 5 years ago

#4427 closed defect (duplicate)

wiki page not created if assigned a tag

Reported by: jouvin@… Owned by: athomas
Priority: high Component: TagsPlugin
Severity: critical Keywords:
Cc: Trac Release: 0.11

Description

Hi,

I just updated from Trac 0.10 to 0.11stable-r7778 and updaded TagsPlugin to the last version at the same time (r3117). Since, when creating a new wiki page and assigning a tag at the same time, the tag is created referencing the page but the wiki page is not created. When re-creating the page, the tag is remembered and everything goes fine. This happens wheter the tag already exists or not.

Cheers,

Michel

Attachments (0)

Change History (11)

comment:1 Changed 5 years ago by jouvin@…

The problem is even worst : this happens for every modification done in a wiki page (not only at creation) when modifying the tags attached to the page at the same time.

Michel

comment:2 Changed 5 years ago by planktr@…

  • Severity changed from major to critical

Hi, i wanted to escallate the severity of this ticket. I am having the same issue, and have just lost an entire new wiki page because I listed a tag as I was creating a new page. None of the data fields are committed when the list of tags change.

comment:3 Changed 5 years ago by anonymous

  • Priority changed from normal to high

comment:4 Changed 5 years ago by jsilence

Same problem here. Lost fresh content due to this. World is not ending, but it is annoying. I would like to invite colleagues to contribute content to our Trac based intranet, but this bug is holding me back. They would be very irritated and frustrated.

comment:5 follow-up: Changed 5 years ago by astroman

Seems the page.text attribute is not populated when validate_wiki_page is called. I patched it to check req.args.get('text') instead which fixed it for me. Patch against 0.6 below.

===================================================================
--- tags/0.6/tractags/wiki.py	(revision 44154)
+++ tags/0.6/tractags/wiki.py	(working copy)
@@ -52,7 +52,7 @@
         if req and 'TAGS_MODIFY' in req.perm(page.resource) \
                 and req.path_info.startswith('/wiki') and 'save' in req.args:
             if self._update_tags(req, page) and \
-                    page.text == page.old_text and \
+                    req.args.get('text', '') == page.old_text and \
                     page.readonly == int('readonly' in req.args):
                 req.redirect(get_resource_url(self.env, page.resource, req.href, version=None))
         return []

comment:6 in reply to: ↑ 5 Changed 5 years ago by thomas.constans@…

Replying to astroman:

Seems the page.text attribute is not populated when validate_wiki_page is called. I patched it to check req.args.get('text') instead which fixed it for me. Patch against 0.6 below.

Just to says:

This patch works for me too

Regards

comment:7 Changed 5 years ago by jouvin@…

Alec and other maintainers,

Any chance to see this patch integrated into the official distribution ?

Michel

comment:8 Changed 5 years ago by athomas

  • Resolution set to fixed
  • Status changed from new to closed

I believe this has been fixed in trunk for some time. If somebody can confirm that, I'll cut a new release soon.

comment:9 Changed 5 years ago by tekknokrat

  • Resolution fixed deleted
  • Status changed from closed to reopened

The patch posted above works but is not in trunk, yet.

comment:10 Changed 5 years ago by dgolden@…

This is pretty annoying if you miss this bug report and deploy 0.6... A new release would be nice.

comment:11 Changed 5 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.