Modify

Opened 5 years ago

Closed 3 years ago

Last modified 3 years ago

#4532 closed defect (worksforme)

Only shortest acronym is matched

Reported by: zeljko Owned by: rjollos
Priority: high Component: AcronymsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

If there are two acronyms where shorter one is equal to beginning of longer one, e.g.

||WS||Web Service|| || ||
||WSDL||Web Service Description Language|| || ||

only the shorter one will be matched, i.e. only "WS" part of "WSDL" will be underlined and only "WS" description will be seen.

Partial match is practical for plurals (e.g. WSDLs), but should be limited to upper case part of the acronym.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by rjollos

  • Description modified (diff)
  • Owner changed from athomas to rjollos
  • Status changed from new to assigned

I can't reproduce this behavior with Trac 0.11.8dev-r9998.

comment:2 Changed 3 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from assigned to closed

Please reopen if it still doesn't work after upgrading to Trac 0.11.7.

comment:3 Changed 3 years ago by rjollos

In fact, the following example works as I expect it to as well:

||RFC||Request For Comment $1||http://www.ietf.org/rfc.html||http://www.ietf.org/rfc/rfc$1.txt||
||RFC2315||Req for comment 2315 || ReqForComment|| ||

In that case, RFC 2315 links to ReqForComment, as I'd expect it to over-ride the match to RFC<id>.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.