Modify

Opened 5 years ago

Closed 4 years ago

#4540 closed enhancement (duplicate)

use svn repo too

Reported by: tac@… Owned by: robert_martin
Priority: normal Component: DiaVisViewPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

is there a way too use svn:/trunk/bla.dia in addition to attachements? Uploading versioned diagrams to wikipages as attachement feels like half the battle.

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by anonymous

I'll investigate to see how this can be done. The Image macro does it OK, so I should be able to use that as a basis. Please allow a couple of weeks, as I don't have much time available.

The Image macro uses source:trunk/bla.dia. Please see the pages on wiki macros.

comment:2 Changed 5 years ago by robert_martin

  • Status changed from new to assigned

By the looks of it the original drawing source file will have to be imported into a local directory. It can then be rendered using dia. This will require some additional work. To minimise page loading times the modification times of the original and rendered png file are compared, and only update the png file if it is older or a different size is wanted. The modification time will probably have to be set using the age of the file in the repository.

I'm assuming that it will always display the newest version.

Another thought might be if there was some form of post commit script that created the png file, and then there was just a simple link from trac to it?

comment:3 Changed 5 years ago by tac@…

writing a hook would be a solution for one diagram, but not for a group of developers with a lot of diagrams and without access at trac serving host. It would ever feel like a hack.

comment:4 Changed 4 years ago by debacle@…

4540 and 6982 seem to be duplicates of 4531 and should be closed as such.

comment:5 Changed 4 years ago by debacle@…

  • Resolution set to duplicate
  • Status changed from assigned to closed

Closed as duplicate of 4531.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from robert_martin. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.