Modify

Opened 5 years ago

Closed 5 years ago

#4564 closed defect (duplicate)

Burndown chart is wrong after moving tickets between milestones

Reported by: anonymous Owned by: hoessler
Priority: normal Component: EstimationToolsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

The plugin assumes that the task list doesn't change during the course of a sprint. This means once a sprint started a team can only add and close, but never move tickets. Moving tickets would alter the burndown chart.

Here are two scenarios where you might want to move tickets:

  • An unplanned issue must be taken care of immediately, one ticket is added to current sprint and to compensate for the extra hours another ticket is moved to next sprint (or "unknown" milestone)
  • The other scenario is at the end of a sprint, unfinished tickets are taken to next sprint

As a result the whole burndown chart is changed (not just from the day a ticket was moved) and shows a wrong chart, depending on whether you moved in or out it shows a graph with too many or too few hours.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by anonymous

The information about moving tickets between milestones can be found in the table 'ticket_change'.

comment:2 Changed 5 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Closed as duplicate of #4669.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hoessler. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.